It is currently Sat Jun 24, 2017 3:40 am



Welcome
Welcome to antiX-forum.

You are currently viewing our boards as a guest, which gives you limited access to view most discussions and access our other features. By joining our free community, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content, and access many other special features. Registration is fast, simple, and absolutely free, so please, join our community today!


Post new topic Reply to topic  [ 7 posts ] 
Author Message
 Post subject: Trying to install Libvirt-bin
PostPosted: Wed Apr 05, 2017 6:35 am 
Offline

Joined: Fri May 15, 2015 2:06 am
Posts: 8
Hello, I am trying to install libvirt-bin and it tells me that it has dependencies
that want libsystemd0. I am running Antix 15 jessie and my antix.list and
debian.list both are pointing to jessie repositories. Both lists are exactly
as provided by the distribution.

I have read the forum entry dated June 16,2016 and when I look at
the daveserver repository I can see the nosystemd version
of libvirt-bin and all it's dependencies.



Some details:

apt-get install libvirt-bin
Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libvirt-bin : Depends: libvirt-daemon-system (>= 1.2.9-9+deb8u3) but it is not going to be installed
Depends: libvirt-clients (>= 1.2.9-9+deb8u3) but it is not going to be installed


apt-get install libvirt-clients
Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libvirt-clients : Depends: libsystemd0 but it is not installable
Depends: libvirt0 (= 1.2.9-9+deb8u3) but it is not going to be installed



Checked the available versions and installation candidate:

apt-cache policy libvirt-bin
libvirt-bin:
Installed: (none)
Candidate: 1.2.9-9+deb8u3
Version table:
1.2.9-9+deb8u3 0
500 http://ftp.us.debian.org/debian/ jessie/main amd64 Packages
500 http://security.debian.org/ jessie/updates/main amd64 Packages
1.2.9-9+deb8u2.0nosystemd1 0
500 http://antix.daveserver.info/jessie/ jessie/nosystemd amd64 Packages

Tried to install the version on the antix repository, tried a couple of times as
different docs show different formats

apt-get install -t libvirt-bin_1.2.9-9+deb8u2.0nosystemd1
Reading package lists... Done
E: The value 'libvirt-bin_1.2.9-9+deb8u2.0nosystemd1' is invalid for APT::Default-Release
as such a release is not available in the sources

apt-get install -t libvirt-bin=1.2.9-9+deb8u2.0nosystemd1
Reading package lists... Done
E: The value 'libvirt-bin=1.2.9-9+deb8u2.0nosystemd1' is invalid for APT::Default-Release
as such a release is not available in the sources

The error message is typically vague, of course.

I have also tried aptitude, it's proposed solution is effectively
"don't install it / can't install it"

My next planned step is to set up a local repository and load the required packages
to it and if I can find a decent document about pinning force apt to install from the
local repository.

The irony here is that qemu works perfectly well without libvirt, it just simplifies
networking etc.

Any ideas / suggestions


Top
 Profile  
 
 Post subject: Re: Trying to install Libvirt-bin
PostPosted: Wed Apr 05, 2017 11:50 am 
Offline
Site Admin
User avatar

Joined: Tue Sep 11, 2007 4:55 pm
Posts: 5833
Location: Greece
This is a transitional package. You can safely remove it.

https://packages.debian.org/jessie/arm64/libvirt-bin

I'll try and build a nosystemd version of the jessie pakage, but according to the debian page linked above it is not needed.

_________________
Philosophers have interpreted the world in many ways; the point is to change it.


Top
 Profile  
 
 Post subject: Re: Trying to install Libvirt-bin
PostPosted: Wed Apr 05, 2017 2:42 pm 
Offline

Joined: Fri May 15, 2015 2:06 am
Posts: 8
Yes, I saw that comment about it being a transitional package. So can I assume that apt will not install the
nosystemd version of libvirt-bin because the version on on the antix repo is labeled deb8u2 and the version on the
debian repo is labeled deb8u3? But I would have thought I could still get apt to install it?


Top
 Profile  
 
 Post subject: Re: Trying to install Libvirt-bin
PostPosted: Wed Apr 05, 2017 3:59 pm 
Offline
Site Admin
User avatar

Joined: Tue Sep 11, 2007 4:55 pm
Posts: 5833
Location: Greece
You will have to wait until the new nosystemd version enters the antix/jessie repo.

_________________
Philosophers have interpreted the world in many ways; the point is to change it.


Top
 Profile  
 
 Post subject: Re: Trying to install Libvirt-bin
PostPosted: Thu Apr 06, 2017 1:17 am 
Offline

Joined: Fri May 15, 2015 2:06 am
Posts: 8
OK, now I am totally puzzled. I found the correct form for the install of older versions of packages and tried to install the 2 dependencies of libvirt-bin, namely libvirt-clients and libvirt-daemon-system, both failed to install. So I worked my way down the dependencies for those packages and installed the packages one at a time, working my way back up the lists. Everything worked. I have carefully checked my system and all seems ok, all relevant packages correctly installed. When I get some time I will try to understand what happened, so no rush with the new packages. Thanks for your time and thanks for a fine distribution.


Top
 Profile  
 
 Post subject: Re: Trying to install Libvirt-bin
PostPosted: Thu Apr 06, 2017 7:52 am 
Offline
Site Admin
User avatar

Joined: Tue Sep 11, 2007 4:55 pm
Posts: 5833
Location: Greece
New packages should now be in the repo.

_________________
Philosophers have interpreted the world in many ways; the point is to change it.


Top
 Profile  
 
 Post subject: Re: Trying to install Libvirt-bin
PostPosted: Thu Apr 06, 2017 5:10 pm 
Offline
Site Admin
User avatar

Joined: Tue Sep 11, 2007 4:55 pm
Posts: 5833
Location: Greece
New nosystemd version now in repos.

_________________
Philosophers have interpreted the world in many ways; the point is to change it.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
suspicion-preferred