It is currently Thu Dec 18, 2014 7:36 am



Welcome
Welcome to antiX-forum.

You are currently viewing our boards as a guest, which gives you limited access to view most discussions and access our other features. By joining our free community, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content, and access many other special features. Registration is fast, simple, and absolutely free, so please, join our community today!


Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: antiX 12 install on Asus EeePC 900 step-by-step
PostPosted: Tue Aug 21, 2012 11:11 am 
Offline

Joined: Sat Jul 14, 2012 11:20 am
Posts: 23
Location: Okinawa, Japan
Using much of what rokytnji did for antiX11 (see links below) and other various links and my limited experience, I took copious notes installing antiX 12 on my Asus EEEPC 900 4gig/16gig dual SSD drive netbook. I didn't include screenshots, because shots in rokytnji antiX11 thread are still pretty relevant.
viewtopic.php?f=4&t=3104
http://yatsite.blogspot.jp/2010/04/anti ... c-900.html
dealing-with-a-asus-eee-900-install-of-antix-8-5-t2328.html


So below are my notes. Use at your own risk! :mrgreen: There some stuff I tested during rc2 (skype, sound, some Fn Keys, etc), so I'll add more as I get around to verifying it on the fresh Final 12 install
Cheers!


Install
Used unetbootin in MEPIS to make a “live” USB drive. (the antix 12 full version took 702 MB )

Insert USB into powered-off EeePC.
Turn on.
At Boot screen, hit ESC and select your USB drive to boot from.
After boot menu loads, at the default option hit TAB to edit boot options.
at the end of the line add vga=788 to set the EeePC’s screen resolution

Now on to connect with Wicd in antiX Control Center (Ctrl-Alt-c) >>> Network tab >> Connect Wirelessly (wicd)

In Wicd preferences (small dropdown arrow on the right side):
enter wlan0 for the wireless interface. (If not sure what your wireless interface is called run ifconfig -a as root)
Refresh and connect to the correct wireless network and as appropriate: adding the key (passphase) and selecting “Connect Automatically”

Now Install (Click the desktop icon)
Use the defaults unless noted:
During step 1, Run partition tool:
1. delete all existing partitions.
2. on sda: create new partition as ext2 file system as a primary / partition
3. on sdb: create new partition as ext2 file system as a primary / partition

Close Partition tool

Make sure “Select Custom install on existing partitions” is selected

Keep default choices of sda1, no swap and /home on root

But, check box for “Preserve data in /home” to keep ext2 file system that we created before intact. ...Making “Filesystem type” not important.

Continue install process. Choose Yes for “OK to use (no format) on /dev/sda1...”
Installation on my EeePC took about 6 minutes

Choose Yes for “Install Grub to MBR on sda?” (assuming no other operating systems on the EeePC)


Update antiX:
antiX Control Center (Ctrl-Alt-c) >>> System >> Manage Packages to open Synaptic
Click Reload
On Left lower side, Click “Status” then Installed (upgradeable).
and then Mark All Upgrades and then Apply


Move /HOME to the 16GB SSD drive
su
mkdir /media/sdb1
mount /dev/sdb1 /media/sdb1

cp -rp /home/user /media/sdb1

Edited fstab using geany:
fstab before:
Quote:
# Pluggable devices are handled by uDev, they are not in fstab
UUID=1bce2c47-0a0f-4ab0-b367-96a8aa9997e6 / auto defaults,noatime 1 1
proc /proc proc defaults 0 0
devpts /dev/pts devpts mode=0622 0 0
# Dynamic entries below
UUID=cfb3ff1b-1dd9-4dd4-ab6d-23698d590357 /media/sdb1 ext2 noauto,users,exec,relatime 0 0


Changed to :
Quote:
# Pluggable devices are handled by uDev, they are not in fstab
UUID=1bce2c47-0a0f-4ab0-b367-96a8aa9997e6 / auto defaults,noatime 1 1
proc /proc proc defaults 0 0
devpts /dev/pts devpts mode=0622 0 0
UUID=cfb3ff1b-1dd9-4dd4-ab6d-23698d590357 /home ext2 defaults,noatime 1 1
# Dynamic entries below


rm -r /home
mkdir /home
Reboot

OOTB Test:
OK: :D
Wireless
Wireless resuming after awake from suspend
Youtube works with sound
Fn Contrast buttons
Fn Suspend button
Fn Wireless on/off
Fn Numlock
webcam with guvcview


Not OK:
:x
Fn LCD/CRT display toggle
Fn Volume buttons
Fn Prt Scn
Suspend when lid gets closed


Top
 Profile  
 
 
 Post subject: Re: antiX 12 install on Asus EeePC 900 step-by-step
PostPosted: Wed Aug 22, 2012 12:49 pm 
Offline

Joined: Sat Jul 14, 2012 11:20 am
Posts: 23
Location: Okinawa, Japan
Skype Install

    Go here: http://www.skype.com/intl/en/get-skype/ ... ter/linux/ and download the Debian 6.0 32 bit version (it will be a .deb file)
    Open terminal and change directory to where you downloaded the deb file - Probably cd /home/user
    Enter su then your root password
    enter dpkg -i skype (then use the Tab button to auto-complete)
    If you get a message about libqt4-network dependency issue like I did, enter:
    apt-get -f install
    Skype should appear in Menu->Applications->Internet.
    Close terminal

OOTB with skype:
built-in webcam video worked fine
Test Sound played fine
Test call: No Microphone

To get mic working
antiX CC >>> Hardware >>> Adjust Mixer - this will open alsamixer.
Hit f5 so that all channels show up and use arrow keys to match these settings - see screenshot:
Master 100%
Headphone 100%
Speaker 100%
PCM 100%
Mic 0 ‘mm’
Mic Boost 0
Capture 70% (also hit space bar to toggle show that ‘L---R Capture” shows in red)
Auto-mute enabled
Digital 71%
Internal Mic 70% (make sure it doesn’t say ‘mm’ by hitting the letter m key)
Internal Mic Boost 0

Make another test call and adjust if needed to suit your desires


Attachments:
File comment: alsamixer settings for EeePC 900
alsamixer.jpg
alsamixer.jpg [ 61.61 KiB | Viewed 4677 times ]
Top
 Profile  
 
 Post subject: Re: antiX 12 install on Asus EeePC 900 step-by-step
PostPosted: Mon Aug 27, 2012 12:41 am 
Offline

Joined: Sat Jul 14, 2012 11:20 am
Posts: 23
Location: Okinawa, Japan
Volume Icon/Hotkeys fix
The Fn Volume/Mutes keys don’t work by default and the Volume icon is hard to see the status, so to fix:
Right Click the volume icon >>> Preferences
For “Icon Theme” select Blue Bar (or other choice that you like)
Down where it says hotkeys:
check the boxes next to:
Volume Up XF86AudioLowerVolume
Volume Down XF86AudioRaiseVolume
Mute XF86AudioMute


Side note: The below is the first fix I tried and it also worked, but then I finally noticed the above fix in the volume icon preferences, which seemed much easier.
aniX cc >>> Desktop >>> Edit IceWM Settings
finds the “keys” tab and add these to the bottom:
key "XF86AudioLowerVolume" amixer -c 0 set Master 5-
key "XF86AudioRaiseVolume" amixer -c 0 set Master 5+
key "XF86AudioMute" amixer -c 0 -- set Master toggle


SUSPEND on LID CLOSE
aniX cc >>> System >>> Edit Config Files

Open /etc /acpi/lid.sh

Find the lines that say:

if [ x$LID_SLEEP = xtrue ]; then
pm-suspend
fi

and add hashtags to the two lines so it looks like this:

# if [ x$LID_SLEEP = xtrue ]; then
pm-suspend
# fi


WICD ICON
Wicd icon doesn’t show on the taskbar at startup...to fix:

aniX cc >>> Desktop >>> Edit IceWM Settings
finds the “startup” tab and remove the hashtag from the sleep line:

# wicd
#sleep 2 && wicd-client -t &

so it looks like this:
# wicd
sleep 2 && wicd-client -t &

The above fix caused conky to not show up on some reboots. In the same startup config file, I added 1 to all sleep values except for wicd and conky seems to be behaving.


TOUCHPAD TOGGLE
(If you are typing and your thumbs always hit the touchpad causing you to mess up your text!)

Step 1:
Create new script with below contents and save as /usr/local/bin/touchpad_toggle.sh

Code:
#!/bin/sh
# touchpad toggle command from commandlinefu.com

if [ $(synclient -l | grep TouchpadOff | awk '{print $3}') = "0" ]; then synclient TouchpadOff=1; elif [ $(synclient -l | grep TouchpadOff | awk '{print $3}') == "1" ]; then synclient TouchpadOff=0; else synclient TouchpadOff=0; fi


Make the touchpad_toggle.sh script executable:
sudo chmod 755 /usr/local/bin/touchpad_toggle.sh

Step 2:
Tie the script to the hotkey F6:
aniX cc >>> Desktop >>> Edit IceWM Settings
finds the “keys” tab and add this line to the bottom:

key "F6" touchpad_toggle.sh


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
suspicion-preferred