antiX-forum
http://antix.freeforums.org/

antiX-17-a2 32 bit only for testing.
http://antix.freeforums.org/antix-17-a2-32-bit-only-for-testing-t6901-15.html
Page 2 of 6

Author:  eugen-b [ Mon Mar 20, 2017 11:45 pm ]
Post subject:  Re: antiX-17-a2 32 bit only for testing.

Hello, it's great to see your progress with the new release!

I tried a live USB, boot with toram option on netbook, lauch the graphical installer, format the USB stick to btrfs, it lets me select the device, but at the next step "manual installation" I cannot select it as root - it is probably to small with 4GB.
I tried another stick with 7.5GB, formattedit btrfs and was able to select it as root, but the next step after confirimg or decline to format the device I get an error message and the process goes back to device selection and partitioning. Then selecting "use entire disk" option I get to complete the installation.

Update: I copied the file system on the SSD into a subvolume, will run it for a while.
Code:
[email protected]:~
$ inxi -Fxxxz
System:    Host: antix17 Kernel: 4.10.1-antix.1-486-smp i686 (32 bit gcc: 6.3.0)
           Desktop: JWM 2.3.6 dm: slim
           Distro: antiX-17.a2_386-full keerfa 19 March 2017
Machine:   Device: laptop System: ASUSTeK product: 1001HA v: x.x
           Mobo: ASUSTeK model: 1005HA v: x.xx
           BIOS: American Megatrends v: 1601 date: 04/18/2011
           Chassis: type: 10 v: x.x
Battery    BAT0: charge: 12.4 Wh 100.0% condition: 12.4/21.5 Wh (57%) volts: 12.3/10.8
           model: ASUS 1005HA Li-ion serial: N/A status: Full cycles: 0
CPU:       Single core Intel Atom N270 (-HT-) cache: 512 KB
           flags: (nx pae sse sse2 sse3 ssse3) bmips: 3199
           clock speeds: min/max: 800/1600 MHz 1: 1600 MHz 2: 1600 MHz
Graphics:  Card: Intel Mobile 945GSE Express Integrated Graphics Controller
           bus-ID: 00:02.0 chip-ID: 8086:27ae
           Display Server: X.Org 1.19.2 drivers: intel (unloaded: modesetting,fbdev,vesa)
           Resolution: [email protected]
           GLX Renderer: Mesa DRI Intel 945GME x86/MMX/SSE2
           GLX Version: 2.1 Mesa 13.0.5 Direct Rendering: Yes
Audio:     Card Intel NM10/ICH7 Family High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0 chip-ID: 8086:27d8
           Sound: Advanced Linux Sound Architecture v: k4.10.1-antix.1-486-smp
Network:   Card-1: Qualcomm Atheros AR8132 Fast Ethernet
           driver: atl1c v: 1.0.1.1-NAPI port: ec00 bus-ID: 01:00.0 chip-ID: 1969:1062
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: <filter>
           Card-2: Ralink RT3090 Wireless 802.11n 1T/1R PCIe
           driver: rt2800pci v: 2.3.0 bus-ID: 02:00.0 chip-ID: 1814:3090
           IF: wlan0 state: down mac: <filter>
Drives:    HDD Total Size: 32.0GB (61.0% used)
           ID-1: /dev/sda model: SAMSUNG_SSD_PM83 size: 32.0GB serial: S0XLNSACA03025
Partition: ID-1: / size: 30G used: 19G (63%) fs: btrfs dev: /dev/sda1
           ID-2: /home size: 30G used: 19G (63%) fs: btrfs dev: /dev/sda1
Sensors:   System Temperatures: cpu: 56.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 158 Uptime: 6 min Memory: 159.2/2008.6MB
           Init: SysVinit v: 2.88 runlevel: 5 default: 5 Gcc sys: 6.3.0
           Client: Shell (bash 4.4.111 running in lxterminal) inxi: 2.3.8

- JWM tray gets covered by maximized windows, not nice. layer="5" is deprecated, man jwm says layer="above" is default. And it works for me.

Author:  ile [ Tue Mar 21, 2017 4:10 am ]
Post subject:  Re: antiX-17-a2 32 bit only for testing.

hello anticapitalista
live usb; not install
Code:
[email protected]:~
$ inxi -b -f -r -xxx -S -W 20500
System:    Host: antix1 Kernel: 4.10.1-antix.1-486-smp i686 (32 bit gcc: 6.3.0)
           Desktop: Fluxbox 1.3.5 dm: slim
           Distro: antiX-17.a2_386-full keerfa 19 March 2017
Machine:   Device: laptop System: IBM product: 2379R1U v: ThinkPad T42
           Mobo: IBM model: 2379R1U BIOS: IBM v: 1RETDRWW (3.23 ) date: 06/18/2007
           Chassis: type: 10
Battery    BAT0: charge: 22.4 Wh 99.4% condition: 22.5/47.5 Wh (47%) volts: 12.5/10.8
           model: SANYO IBM-92P1075 Li-ion serial: 5554 status: Charging cycles: 0
CPU:       Single core Intel Pentium M (-UP-) cache: 2048 KB
           bmips: 3197 speed/min/max: 1600/600/1600 MHz
           CPU Flags: acpi bts clflush cmov cx8 de dts est fpu fxsr mca mce mmx msr
           mtrr pbe pge pse sep ss sse sse2 tm tm2 tsc vme
Graphics:  Card: Advanced Micro Devices [AMD/ATI] RV200/M7 [Mobility Radeon 7500]
           bus-ID: 01:00.0 chip-ID: 1002:4c57
           Display Server: X.Org 1.19.2 drivers: ati,radeon (unloaded: modesetting,fbdev,vesa)
           Resolution: [email protected]
           GLX Renderer: Mesa DRI R100 (RV200 4C57) x86/MMX/SSE2 DRI2
           GLX Version: 1.3 Mesa 13.0.5 Direct Rendering: Yes
Network:   Card: Intel 82540EP Gigabit Ethernet Controller (Mobile)
           driver: e1000 v: 7.3.21-k8-NAPI port: 8000
           bus-ID: 02:01.0 chip-ID: 8086:101e
Drives:    HDD Total Size: 115.6GB (5.8% used)
Repos:     Active apt sources in file: /etc/apt/sources.list.d/antix.list
           deb http://repo.antixlinux.com/stretch stretch main nosystemd
           Active apt sources in file: /etc/apt/sources.list.d/debian.list
           deb http://ftp.us.debian.org/debian/ stretch main contrib non-free
           deb http://security.debian.org/ stretch/updates main contrib non-free
Weather:   Weather data failure: Mon Mar 20 18:09:26 UTC 2017
           Error: weather info downloaded but no data detected.
Info:      Processes: 119 Uptime: 49 min Memory: 104.6/1002.4MB
           Init: SysVinit v: 2.88 runlevel: 5 default: 5 Gcc sys: 6.3.0
           Client: Shell (bash 4.4.111 running in lxterminal) inxi: 2.3.8

Author:  skidoo [ Tue Mar 21, 2017 7:07 pm ]
Post subject:  Re: antiX-17-a2 32 bit only for testing.

SamK wrote:
The use of this key-combo requires a deliberate action on the part of the user. If the user does not exercise due care and attention, or uses any key-combo without knowing what is the underlying action, they must accept the consequence of their behaviour. Disabling an integral part of a shipped antiX app to cater for the errors of a careless user is not to be adopted.

all your face are belong to us

Image

Image

Author:  Colonel Panic [ Tue Mar 21, 2017 9:55 pm ]
Post subject:  Re: antiX-17-a2 32 bit only for testing.

I tried it this morning although I didn't install it, and found it wouldn't set up networking automatically (which antiX 16.1 will) so I wasn't able to use it to access the Internet.

To be fair, my system is somewhat tricky in this regard and even authorised releases of distros such as CentOS (7) and Slackware (14.2) have been unable to detect my network card in the past.

Author:  skidoo [ Tue Mar 21, 2017 10:02 pm ]
Post subject:  Re: antiX-17-a2 32 bit only for testing.

@ColonialPicnic
refer to post #1
Quote:
user will need to use ceni to connect (wlan and/or ethernet).

Author:  anticapitalista [ Tue Mar 21, 2017 10:21 pm ]
Post subject:  Re: antiX-17-a2 32 bit only for testing.

I would appreciate people testing out an installed version on real hardware (not virtual). Especially to see if the nvidia and/or ati installer app works. Does bootrepair work? How about flash or codecs app? Or luckybackup?
These are the most important things that need testing?

Author:  Shay [ Wed Mar 22, 2017 1:11 am ]
Post subject:  Re: antiX-17-a2 32 bit only for testing.

Maybe a one off but the section for entering name and password was skipped the first install.
Reinstalled , same stick, was fine.

Code:
System:    Host: antix17-32 Kernel: 4.10.1-antix.1-486-smp i686 (32 bit)
           Desktop: IceWM 1.3.8+mod+20161220
           Distro: antiX-17.a2_386-full keerfa 19 March 2017
Machine:   Device: laptop System: Dell product: Latitude E6430 v: 01
           Mobo: Dell model: 0H3MT5 v: A00 BIOS: Dell v: A17 date: 08/19/2015
Battery    BAT0: charge: 90.0 Wh 123.6% condition: 72.8/90.0 Wh (81%)
CPU:       Dual core Intel Core i5-3320M (-HT-MCP-) cache: 3072 KB
           clock speeds: max: 3300 MHz 1: 1878 MHz 2: 1289 MHz 3: 1207 MHz 4: 1218 MHz
Graphics:  Card-1: Intel 3rd Gen Core processor Graphics Controller
           Card-2: NVIDIA GF108GLM [NVS 5200M]
           Display Server: X.Org 1.19.2 drivers: modesetting,nouveau (unloaded: fbdev,vesa)
           Resolution: [email protected]
           GLX Renderer: Mesa DRI Intel Ivybridge Mobile x86/MMX/SSE2
           GLX Version: 3.0 Mesa 13.0.5
Audio:     Card Intel 7 Series/C216 Family High Definition Audio Controller
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.10.1-antix.1-486-smp
Network:   Card-1: Intel 82579LM Gigabit Network Connection driver: e1000e
           IF: eth0 state: down mac: d4:be:d9:86:d8:c7
           Card-2: Intel Centrino Ultimate-N 6300 driver: iwlwifi
           IF: wlan0 state: up mac: 24:77:03:df:1e:94
Drives:    HDD Total Size: 120.0GB (6.0% used)
           ID-1: /dev/sda model: TOSHIBA_MK1234GS size: 120.0GB
Partition: ID-1: / size: 106G used: 2.7G (3%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 4.58GB used: 0.00GB (0%) fs: swap dev: /dev/sda3
Sensors:   System Temperatures: cpu: 54.0C mobo: N/A gpu: 48.0
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 165 Uptime: 7 min Memory: 253.6/3215.8MB
           Client: Shell (bash) inxi: 2.3.8


NVidia driver installer will not even open. Button flashes and that is it.

Author:  anticapitalista [ Wed Mar 22, 2017 1:27 am ]
Post subject:  Re: antiX-17-a2 32 bit only for testing.

Shay - I noticed the same 2 things you mentioned. Bugfix control centre to fix nvidia driver installer on its way to the repos.

Author:  Shay [ Wed Mar 22, 2017 1:56 am ]
Post subject:  Re: antiX-17-a2 32 bit only for testing.

How would one access that?

For the heck tried the ATI button too. Nothing also.

Author:  dolphin_oracle [ Wed Mar 22, 2017 1:57 am ]
Post subject:  Re: antiX-17-a2 32 bit only for testing.

running live:

some notes.

1. when leaving icewm to another wm, then coming back, format of workspace area changes. (sometimes 1 2, sometime alpha, beta)

2. changing theme in icewm makes conky get a little weird

3. there is a another automount-antix in my github if interested. i worked with skiddoo on it. I haven't tried it on the alpha 2 yet.

4. broadcom-manager seems to work fine

5. codecs works fine.

6. nice mpv/gnome-mpv. although playing a dvd was less than intuitative, it does work (hint: easier to drap /media/sr0 into the player)

7. icewm battery monitor!

8. spacefm configuration not quite right, should enable "show internal drives" and disable "unmount of exit" to be more consistent with other file manager defaults.

dev_show_internal_drives-b=1
dev_unmount_quit-b=2

9. inxi -F

Code:
$ [email protected]:~
$ inxi -F
System:    Host: antix1 Kernel: 4.10.1-antix.1-486-smp i686 (32 bit) Desktop: Blackbox
           Distro: antiX-17.a2_386-full keerfa 19 March 2017
Machine:   Device: laptop System: LENOVO product: 2392APU v: ThinkPad T530
           Mobo: LENOVO model: 2392APU v: 0B98401 Pro
           UEFI: LENOVO v: G4ET98WW (2.58 ) date: 11/26/2013
Battery    BAT0: charge: 39.0 Wh 68.1% condition: 57.2/56.2 Wh (102%)
CPU:       Dual core Intel Core i5-3320M (-HT-MCP-) cache: 3072 KB
           clock speeds: max: 3300 MHz 1: 2136 MHz 2: 1263 MHz 3: 1232 MHz 4: 1345 MHz
Graphics:  Card: Intel 3rd Gen Core processor Graphics Controller
           Display Server: X.Org 1.19.2 drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: [email protected]
           GLX Renderer: Mesa DRI Intel Ivybridge Mobile x86/MMX/SSE2
           GLX Version: 3.0 Mesa 13.0.5
Audio:     Card Intel 7 Series/C216 Family High Definition Audio Controller
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.10.1-antix.1-486-smp
Network:   Card-1: Intel 82579LM Gigabit Network Connection driver: e1000e
           IF: eth0 state: down mac: 3c:97:0e:ef:2e:76
           Card-2: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi
           IF: wlan0 state: up mac: e0:9d:31:2e:b7:d0
Drives:    HDD Total Size: 324.1GB (2.5% used)
           ID-1: /dev/sda model: HITACHI_HTS72323 size: 320.1GB
           ID-2: USB /dev/sdb model: Cruzer_Glide size: 4.0GB
Partition: ID-1: / size: 1.5G used: 83M (7%) fs: overlay dev: N/A
           ID-2: /home size: 406M used: 6.5M (2%) fs: ext4 dev: /dev/loop2
           ID-3: swap-1 size: 8.59GB used: 0.00GB (0%) fs: swap dev: /dev/sda7
Sensors:   System Temperatures: cpu: 46.0C mobo: N/A
           Fan Speeds (in rpm): cpu: 0
Info:      Processes: 164 Uptime: 39 min Memory: 267.0/3306.0MB
           Client: Shell (bash) inxi: 2.3.8

$


note that the desktop is reported as Blackbox. I'm running icewm.

Author:  Shay [ Wed Mar 22, 2017 2:39 am ]
Post subject:  Re: antiX-17-a2 32 bit only for testing.

Quote:
Does bootrepair work?


Seems to work fine for me.

Running the backup right now to a USB stick
EDITBacked up the folders I selected.

Gparted is not listed in the menu, so I ran it from terminal. Had to prep the stick.

Author:  anticapitalista [ Wed Mar 22, 2017 10:31 am ]
Post subject:  Re: antiX-17-a2 32 bit only for testing.

Gparted is in the control centre

Author:  eugen-b [ Wed Mar 22, 2017 7:50 pm ]
Post subject:  Re: antiX-17-a2 32 bit only for testing.

The USB install on the netbook boots on my AMD machine, too.
Code:
[email protected]:~
$ inxi -Fxxxz
System:    Host: antix17 Kernel: 4.10.1-antix.1-486-smp i686 (32 bit gcc: 6.3.0)
           Desktop: IceWM 1.3.8+mod+20161220 dm: slim
           Distro: antiX-17.a2_386-full keerfa 19 March 2017
Machine:   Device: desktop System: ASUS product: All Series
           Mobo: ASUSTeK model: AM1I-A v: Rev X.0x
           BIOS: American Megatrends v: 0505 date: 03/13/2014
CPU:       Quad core AMD Sempron 3850 APU with Radeon R3 (-MCP-) cache: 8192 KB
           flags: (lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 10380
           clock speeds: min/max: 800/1300 MHz 1: 1000 MHz 2: 800 MHz 3: 800 MHz
           4: 800 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Kabini [Radeon HD 8280 / R3 Series]
           bus-ID: 00:01.0 chip-ID: 1002:9836
           Display Server: X.Org 1.19.2 drivers: ati,radeon (unloaded: modesetting,fbdev,vesa)
           Resolution: [email protected]
           GLX Renderer: Gallium 0.4 on AMD KABINI (DRM 2.49.0 / 4.10.1-antix.1-486-smp, LLVM 3.9.1)
           GLX Version: 3.0 Mesa 13.0.5 Direct Rendering: Yes
Audio:     Card-1 Advanced Micro Devices [AMD] FCH Azalia Controller
           driver: snd_hda_intel bus-ID: 00:14.2 chip-ID: 1022:780d
           Card-2 Advanced Micro Devices [AMD/ATI] Kabini HDMI/DP Audio
           driver: snd_hda_intel bus-ID: 00:01.1 chip-ID: 1002:9840
           Sound: Advanced Linux Sound Architecture v: k4.10.1-antix.1-486-smp
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: e000 bus-ID: 01:00.0 chip-ID: 10ec:8168
           IF: eth1 state: down mac: <filter>
           Card-2: Ralink RT5572 Wireless Adapter
           driver: rt2800usb v: 2.3.0 usb-ID: 001-003 chip-ID: 148f:5572
           IF: wlan1 state: N/A mac: N/A
Drives:    HDD Total Size: 540.1GB (0.9% used)
           ID-1: /dev/sda model: LITEONIT_LSS size: 32.0GB serial: 002322107912
           ID-2: /dev/sdb model: ST500LM012_HN size: 500.1GB serial: S2R7J9EF300175
           ID-3: USB /dev/sdc model: USB_Flash_Disk size: 8.0GB
           serial: FF06000000000003-0:0
Partition: ID-1: / size: 6.3G used: 3.5G (58%) fs: ext4 dev: /dev/sdc1
           ID-2: swap-1 size: 1.07GB used: 0.00GB (0%) fs: swap dev: /dev/sdc2
Sensors:   System Temperatures: cpu: 19.4C mobo: N/A gpu: 20.0
           Fan Speeds (in rpm): cpu: 0
Info:      Processes: 155 Uptime: 2 min Memory: 104.4/2476.1MB
           Init: SysVinit v: 2.88 runlevel: 5 default: 5 Gcc sys: 6.3.0
           Client: Shell (bash 4.4.111 running in lxterminal) inxi: 2.3.8

I will try to install the proprietary driver,not sure if it works with this GPU (amdgpu driver works on it, FWIIW).

- A little problem: Firefox doesn't follow the keymap settings from CC, I had to run setxkbmap de.

Installing PAE kernel with metapackage installer worked. But clicking AMD/ATI flgrx installer in CC doesn't open any window.

Edit: Install restricted codecs worked.

Author:  anticapitalista [ Wed Mar 22, 2017 8:43 pm ]
Post subject:  Re: antiX-17-a2 32 bit only for testing.

eugen-b wrote:
But clicking AMD/ATI flgrx installer in CC doesn't open any window.


see a couple of posts above yours

Author:  kmathern [ Wed Mar 22, 2017 10:08 pm ]
Post subject:  Re: antiX-17-a2 32 bit only for testing.

anticapitalista wrote:
eugen-b wrote:
But clicking AMD/ATI flgrx installer in CC doesn't open any window.


see a couple of posts above yours
fglrx was removed from Stretch a year or so ago because it doesn't support Xorg versions 1.18 and higher (Stretch is using Xorg 1.19.2), so there's nothing to install.

Page 2 of 6 All times are UTC + 2 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/