It is currently Sun Apr 23, 2017 7:49 pm



Welcome
Welcome to antiX-forum.

You are currently viewing our boards as a guest, which gives you limited access to view most discussions and access our other features. By joining our free community, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content, and access many other special features. Registration is fast, simple, and absolutely free, so please, join our community today!


Post new topic Reply to topic  [ 12 posts ] 
Author Message
 Post subject: Unable to type accented characters [SOLVED - sort of]
PostPosted: Tue May 08, 2012 1:00 pm 
Offline

Joined: Sat Sep 03, 2011 5:28 pm
Posts: 35
Location: England
I've been running Antix on a Dell 2400 desktop for months, and it's great. So far, there's only one cause for puzzlement. I can't find a way to type accented characters. This should be easy, as I've done it on an xubuntu system by simply including the command "setxkbmap -option compose:rwin" in the "Session and Startup" settings. I'm using xfce for the desktop under Antix, so did the same here - no effect. OK, says I, I'll just run the command in Terminal and see what happens. No, that doesn't work. Here's what I get from printing out the basic setxkbmap:

$ setxkbmap -print
xkb_keymap {
xkb_keycodes { include "evdev+aliases(qwerty)" };
xkb_types { include "complete" };
xkb_compat { include "complete" };
xkb_symbols { include "pc+gb+inet(evdev)+terminate(ctrl_alt_bksp)" };
xkb_geometry { include "pc(pc105)" };
};

I then set the 'compose' key to be the RH Windows key . . .

$ setxkbmap -option compose:rwin

. . . and print the result . . .

$ setxkbmap -print
xkb_keymap {
xkb_keycodes { include "evdev+aliases(qwerty)" };
xkb_types { include "complete" };
xkb_compat { include "complete" };
xkb_symbols { include "pc+gb+inet(evdev)+compose(rwin)+terminate(ctrl_alt_bksp)" };
xkb_geometry { include "pc(pc105)" };
};
$
So, it seems to have taken the command but I still can't type any accented characters. I've tried the left Windows key (compose:lwin), and in desperation tried another keyboard, so I'm convinced it's not a hardware problem. I can't get the compose key to work under icewm either . . . is there something I've overlooked?

Any suggestions welcome.


Last edited by rustiguzzi on Thu Jan 31, 2013 7:15 pm, edited 1 time in total.

Top
 Profile  
 
 Post subject: Re: Unable to type accented characters
PostPosted: Wed May 09, 2012 11:20 pm 
Offline
User avatar

Joined: Sun Apr 29, 2012 8:08 pm
Posts: 21
Location: Croatia
Have you tried with "dpkg-reconfigure keyboard-configuration" as root?

_________________
Omnia sunt communia.


Top
 Profile  
 
 Post subject: Re: Unable to type accented characters
PostPosted: Thu May 10, 2012 12:17 pm 
Offline

Joined: Sat Sep 03, 2011 5:28 pm
Posts: 35
Location: England
Interesting - not heard of this command before. Tried it, and although it successfully added the compose key as before, it still doesn't do anything. Had me wondering about the keyboard, so went from "English (UK)" to "English (UK with extended Winkeys)" to no effect. All back to original now, but setxkbmap now has "level3(ralt_switch)" in the "xkb_symbols" line, which I can't get rid of.

Also, funny things are happening with the mouse - drop-down menus disappear when you try and select an item with it, and the pointer itself becomes a large X when outside this window. Plus, the Terminal window cannot be moved . . . probably hit a wrong key and upset the system somehow. The saga continues . . .


Top
 Profile  
 
 Post subject: Re: Unable to type accented characters
PostPosted: Thu May 10, 2012 12:46 pm 
Offline

Joined: Sat Sep 03, 2011 5:28 pm
Posts: 35
Location: England
. . . but meanwhile, I've found that reverting to icewm has solved the additional problems mentioned above, such as the strange behaviour of the mouse pointer and the immovable Terminal window (which had also lost its flashing cursor, by the way). So for the time being, I've quit xfce for icewm - I'll see if I can sort out xfce later, meanwhile any suggestions regarding the original query are welcome.


Top
 Profile  
 
 Post subject: Re: Unable to type accented characters
PostPosted: Thu May 10, 2012 3:03 pm 
Offline
User avatar

Joined: Sun Apr 29, 2012 8:08 pm
Posts: 21
Location: Croatia
"dpkg-reconfigure keyboard-configuration" sets defaults for the whole system, but you can still change keyboard for a particular X session. Recently I was trying to change the keyboard from english to croatian with that command, and it worked in non-X sesssions (i.e. in tty 1-6), but not in my IceWM session. Then I found out that in my IceWM startup script I had setxkbmap set to english US. When I set that to croatian too, everything was fine.
So, what I am trying to say is that you should probably use both approaches to have good results.

But after all you said now, not sure if maybe you have some deeper problems with xorg itself...

But anyway, test your keyboard outside of X, for a start, just to make sure if it is the keyboard itself or an xorg problem.

_________________
Omnia sunt communia.


Top
 Profile  
 
 Post subject: Re: Unable to type accented characters
PostPosted: Thu May 10, 2012 5:13 pm 
Offline

Joined: Sat Sep 03, 2011 5:28 pm
Posts: 35
Location: England
Excellent suggestion! I came out of the current X-session with Ctrl.Alt.F1, and at the login prompt typed some characters with the rwin key - not all worked, but I got acute, grave and circumflex accents, umlauts and the sharp S (German 'ss').

So the system has the capability to do these characters, the problem lies within X. Not sure where we go from here, but it's a start. It's not a serious problem, fortunately, as I don't use this machine for mail - just annoying.

For what it's worth, ibus enables me to input in Japanese, it's just odd that I can't get "Latin" characters with accents on.


Top
 Profile  
 
 Post subject: Re: Unable to type accented characters
PostPosted: Thu May 10, 2012 5:33 pm 
Offline
User avatar

Joined: Sun Apr 29, 2012 8:08 pm
Posts: 21
Location: Croatia
rustiguzzi wrote:
For what it's worth, ibus enables me to input in Japanese, it's just odd that I can't get "Latin" characters with accents on.


Totally! :-D

But, what happens if you remove all setxkbmap modifications from your session?
I guess in this situation xorg should take up the system-wide defaults...

_________________
Omnia sunt communia.


Top
 Profile  
 
 Post subject: Re: Unable to type accented characters
PostPosted: Fri May 11, 2012 9:28 pm 
Offline

Joined: Sat Sep 03, 2011 5:28 pm
Posts: 35
Location: England
Been thinking about this . . . not sure how to remove all setxkbmap mods. I tried "setxkbmap -option" which, I thought, would do the trick but following it with "setxkbmap -print" showed that nothing had changed. Can't think where to go from here.

FWIW . . .

/etc/X11/xorg.conf has
Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
EndSection

Doing this command gives a bit of info:
$ setxkbmap -query
rules: evdev
model: pc105
layout: gb
options: lv3:ralt_switch,compose:rwin,terminate:ctrl_alt_bksp

And finally, these lines are in .icewm/startup:
# set live keyboard
#setxkbmap
so where is xkbmap being set?

I don't know whether there are any clues in there. I have this feeling of being out of my depth . . .


Top
 Profile  
 
 Post subject: Re: Unable to type accented characters
PostPosted: Fri May 11, 2012 9:47 pm 
Online
Site Admin
User avatar

Joined: Tue Sep 11, 2007 4:55 pm
Posts: 5781
Location: Greece
/etc/default/keyboard

_________________
Philosophers have interpreted the world in many ways; the point is to change it.


Top
 Profile  
 
 Post subject: Re: Unable to type accented characters
PostPosted: Sat May 12, 2012 12:12 am 
Offline
User avatar

Joined: Sun Apr 29, 2012 8:08 pm
Posts: 21
Location: Croatia
Yes, but isn't this file the system-wide default?
If I understand it good, rustiguzzi now has it setup good for the system itself, but not for the X session. I.e. out of X, the accented characters work, but inside an X session not. The question is, how to syncronize the two?

_________________
Omnia sunt communia.


Top
 Profile  
 
 Post subject: Re: Unable to type accented characters
PostPosted: Tue May 15, 2012 9:49 pm 
Offline

Joined: Sat Sep 03, 2011 5:28 pm
Posts: 35
Location: England
FWIW, /etc/default/keyboard contains:

XKBMODEL="pc105"
XKBLAYOUT="gb"
XKBVARIANT=""
XKBOPTIONS="lv3:ralt_switch,compose:rwin,terminate:ctrl_alt_bksp"

So, my question is . . . how come the compose key works (for some, but not all, accented characters) when out of X yet not at all inside an X session?

It's not often I need to enter words like "smörgåsbord", but it would be great if I could (I'm using a different computer this evening).


Top
 Profile  
 
 Post subject: Re: Unable to type accented characters [solved, sort of]
PostPosted: Thu Jan 31, 2013 7:05 pm 
Offline

Joined: Sat Sep 03, 2011 5:28 pm
Posts: 35
Location: England
Well, I never did get to the bottom of this one, but I recently upgraded to Edelweißpiraten and, after screwing up the system, did a clean reinstall. The command

setxkbmap -option compose:rwin

works now, so I've added it to the .icewm startup file, having decided that Icewm is now my preferred desktop.

It's great to be able to type "Edelweißpiraten".


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 12 posts ] 


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
suspicion-preferred