It is currently Wed Apr 26, 2017 11:44 am



Welcome
Welcome to antiX-forum.

You are currently viewing our boards as a guest, which gives you limited access to view most discussions and access our other features. By joining our free community, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content, and access many other special features. Registration is fast, simple, and absolutely free, so please, join our community today!


Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: Program to help lose weight,,recipe,diet,exercise, nutrients
PostPosted: Wed Jan 18, 2017 7:07 am 
Offline

Joined: Fri Feb 27, 2009 10:17 am
Posts: 563
I have a program on Windoze called Fitday that is pretty good, but not having much luck finding a similar Linux program.

The only one so far is Krecipes, but it requires KDE and doesn't track exercise, I don't think

Any ideas? I tried installing some KDE programs, but none of the games work , which I'd like to have if I need to load all the other KDE stuff just to get the recipe program.

Any Ideas?

_________________
Too many computers, in use now:
1-Dell D620 2gb
2-HP DV9917 4gb
3-Dell E5540 8gb
4-Dell Inspiron 15 7559 16gb
various older machines


Top
 Profile  
 
 Post subject: Re: Program to help lose weight,,recipe,diet,exercise, nutri
PostPosted: Wed Jan 18, 2017 3:33 pm 
Offline
User avatar

Joined: Fri Feb 20, 2009 3:44 am
Posts: 3957
Location: Pecos, Texas
http://www.datamation.com/open-source/7 ... ife-1.html

https://sourceforge.net/projects/cronometer/
https://sourceforge.net/projects/idiet/ ... t%201.0.5/
http://turtlesport.sourceforge.net/EN/download.html

I did a apt search diet and saw what you mean by krecipes. Thing is. You can install krecipes I would think in AntiX without pulling in KDE. Let me check for you.

Code:
$ sudo apt-get install -s krecipes
[sudo] password for harry:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  docbook-xsl kate-data katepart kde-runtime kde-runtime-data kdebase-runtime kdelibs-bin kdelibs5-data kdelibs5-plugins kdoctools krecipes-data libattica0.4 libdbusmenu-qt2
  libdlrestrictions1 libexiv2-13 libfam0 libgpgme++2 libiodbc2 libkactivities6 libkatepartinterfaces4 libkcmutils4 libkde3support4 libkdeclarative5 libkdecore5 libkdesu5
  libkdeui5 libkdewebkit5 libkdnssd4 libkemoticons4 libkfile4 libkhtml5 libkio5 libkjsapi4 libkjsembed4 libkmediaplayer4 libknewstuff3-4 libknotifyconfig4 libkntlm4
  libkparts4 libkpty4 libkrosscore4 libktexteditor4 libkxmlrpcclient4 libnepomuk4 libnepomukquery4a libnepomukutils4 libnl-route-3-200 libntrack-qt4-1 libntrack0 libphonon4
  libplasma3 libpolkit-qt-1-1 libqca2 libqimageblitz4 libqt4-dbus libqt4-declarative libqt4-designer libqt4-qt3support libqt4-sql libsolid4 libsoprano4 libssh-gcrypt-4
  libstreamanalyzer0 libstreams0 libthreadweaver4 libutempter0 libxml2-utils ntrack-module-libnl-0 oxygen-icon-theme phonon phonon-backend-vlc plasma-scriptengine-javascript
  soprano-daemon vlc-plugin-pulse
Suggested packages:
  dbtoepub docbook-xsl-doc-html docbook-xsl-doc-pdf docbook-xsl-doc-text docbook-xsl-doc docbook-xsl-saxon fop libsaxon-java libxalan2-java libxslthl-java xalan
  djvulibre-bin finger icoutils libcanberra-pulse sound-theme-freedesktop libqt4-sql-mysql libqt4-sql-psql mysql-client postgresql-client krecipes-doc exiv2 fam iodbc hspell
  libqca2-plugin-cyrus-sasl libqca2-plugin-gnupg libqca2-plugin-ossl libqt4-declarative-folderlistmodel libqt4-declarative-gestures libqt4-declarative-particles
  libqt4-declarative-shaders qt4-qmlviewer libqt4-dev media-player-info phonon-backend-gstreamer phonon-backend-mplayer virtuoso-minimal
Recommended packages:
  libqt4-sql-sqlite sqlite3 libkactivities-bin
The following NEW packages will be installed:
  docbook-xsl kate-data katepart kde-runtime kde-runtime-data kdebase-runtime kdelibs-bin kdelibs5-data kdelibs5-plugins kdoctools krecipes krecipes-data libattica0.4
  libdbusmenu-qt2 libdlrestrictions1 libexiv2-13 libfam0 libgpgme++2 libiodbc2 libkactivities6 libkatepartinterfaces4 libkcmutils4 libkde3support4 libkdeclarative5
  libkdecore5 libkdesu5 libkdeui5 libkdewebkit5 libkdnssd4 libkemoticons4 libkfile4 libkhtml5 libkio5 libkjsapi4 libkjsembed4 libkmediaplayer4 libknewstuff3-4
  libknotifyconfig4 libkntlm4 libkparts4 libkpty4 libkrosscore4 libktexteditor4 libkxmlrpcclient4 libnepomuk4 libnepomukquery4a libnepomukutils4 libnl-route-3-200
  libntrack-qt4-1 libntrack0 libphonon4 libplasma3 libpolkit-qt-1-1 libqca2 libqimageblitz4 libqt4-dbus libqt4-declarative libqt4-designer libqt4-qt3support libqt4-sql
  libsolid4 libsoprano4 libssh-gcrypt-4 libstreamanalyzer0 libstreams0 libthreadweaver4 libutempter0 libxml2-utils ntrack-module-libnl-0 oxygen-icon-theme phonon
  phonon-backend-vlc plasma-scriptengine-javascript soprano-daemon vlc-plugin-pulse
0 upgraded, 75 newly installed, 0 to remove and 0 not upgraded.
Inst libattica0.4 (0.4.2-1 Debian:8.7/stable [i386])
Inst libqt4-dbus (4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1 Debian:8.7/stable [i386])
Inst libdbusmenu-qt2 (0.9.2-1 Debian:8.7/stable [i386])
Inst libexiv2-13 (0.24-4.1 Debian:8.7/stable [i386])
Inst libiodbc2 (3.52.9-2 Debian:8.7/stable [i386])
Inst libnl-route-3-200 (3.2.24-2 Debian:8.7/stable [i386])
Inst libphonon4 (4:4.8.0-4 Debian:8.7/stable [i386])
Inst libqca2 (2.0.3-6 Debian:8.7/stable [i386])
Inst libqt4-sql (4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1 Debian:8.7/stable [i386])
Inst libqt4-declarative (4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1 Debian:8.7/stable [i386])
Inst libqt4-designer (4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1 Debian:8.7/stable [i386])
Inst libqt4-qt3support (4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1 Debian:8.7/stable [i386])
Inst libssh-gcrypt-4 (0.6.3-4+deb8u2 Debian:8.7/stable, Debian-Security:8/stable [i386])
Inst vlc-plugin-pulse (2.2.4-1~deb8u1 Debian:8.7/stable, Debian-Security:8/stable [all])
Inst phonon-backend-vlc (0.8.0-2 Debian:8.7/stable [i386])
Inst docbook-xsl (1.78.1+dfsg-1 Debian:8.7/stable [all])
Inst kate-data (4:4.14.2-2 Debian:8.7/stable [all])
Inst libdlrestrictions1 (0.15.15 Debian:8.7/stable [i386])
Inst libfam0 (2.7.0-17.1 Debian:8.7/stable [i386])
Inst libkdecore5 (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Inst libkdeui5 (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Inst libkcmutils4 (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Inst soprano-daemon (2.9.4+dfsg-1.1 Debian:8.7/stable [i386])
Inst libsoprano4 (2.9.4+dfsg-1.1 Debian:8.7/stable [i386])
Inst libnepomuk4 (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Inst libsolid4 (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Inst libstreams0 (0.7.8-1.2+b2 Debian:8.7/stable [i386])
Inst libstreamanalyzer0 (0.7.8-1.2+b2 Debian:8.7/stable [i386])
Inst libkio5 (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Inst libknewstuff3-4 (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Inst libnepomukquery4a (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Inst libnepomukutils4 (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Inst libkparts4 (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Inst libktexteditor4 (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Inst libkatepartinterfaces4 (4:4.14.2-2 Debian:8.7/stable [i386])
Inst katepart (4:4.14.2-2 Debian:8.7/stable [i386])
Inst kde-runtime-data (4:4.14.2-2 Debian:8.7/stable [all])
Inst libkjsapi4 (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Inst libkjsembed4 (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Inst libkrosscore4 (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Inst kdelibs-bin (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Inst kdelibs5-data (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [all])
Inst libxml2-utils (2.9.1+dfsg1-5+deb8u4 Debian:8.7/stable, Debian-Security:8/stable [i386])
Inst kdoctools (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Inst libutempter0 (1.1.5-4 Debian:8.7/stable [i386])
Inst libkpty4 (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Inst libkde3support4 (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Inst libkdewebkit5 (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Inst libkemoticons4 (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Inst libkfile4 (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Inst libkhtml5 (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Inst libkntlm4 (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Inst libpolkit-qt-1-1 (0.103.0-1 Debian:8.7/stable [i386])
Inst kdelibs5-plugins (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Inst oxygen-icon-theme (4:4.14.0-1 Debian:8.7/stable [all])
Inst libkdnssd4 (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Inst libthreadweaver4 (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Inst libplasma3 (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Inst plasma-scriptengine-javascript (4:4.14.2-2 Debian:8.7/stable [i386])
Inst libgpgme++2 (4:4.14.2-2+deb8u2 Debian:8.7/stable, Debian-Security:8/stable [i386])
Inst libkactivities6 (4:4.13.3-1 Debian:8.7/stable [i386])
Inst libkdeclarative5 (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Inst libkdesu5 (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Inst libkmediaplayer4 (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Inst libknotifyconfig4 (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Inst libkxmlrpcclient4 (4:4.14.2-2+deb8u2 Debian:8.7/stable, Debian-Security:8/stable [i386])
Inst ntrack-module-libnl-0 (016-1.3 Debian:8.7/stable [i386]) []
Inst libntrack0 (016-1.3 Debian:8.7/stable [i386])
Inst libntrack-qt4-1 (016-1.3 Debian:8.7/stable [i386])
Inst phonon (4:4.8.0-4 Debian:8.7/stable [i386])
Inst kde-runtime (4:4.14.2-2 Debian:8.7/stable [i386])
Inst krecipes-data (2.0~beta2-3 Debian:8.7/stable [all])
Inst kdebase-runtime (4:4.14.2-2 Debian:8.7/stable [all])
Inst libqimageblitz4 (1:0.0.6-4 Debian:8.7/stable [i386])
Inst krecipes (2.0~beta2-3 Debian:8.7/stable [i386])
Conf libattica0.4 (0.4.2-1 Debian:8.7/stable [i386])
Conf libqt4-dbus (4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1 Debian:8.7/stable [i386])
Conf libdbusmenu-qt2 (0.9.2-1 Debian:8.7/stable [i386])
Conf libexiv2-13 (0.24-4.1 Debian:8.7/stable [i386])
Conf libiodbc2 (3.52.9-2 Debian:8.7/stable [i386])
Conf libnl-route-3-200 (3.2.24-2 Debian:8.7/stable [i386])
Conf libphonon4 (4:4.8.0-4 Debian:8.7/stable [i386])
Conf libqca2 (2.0.3-6 Debian:8.7/stable [i386])
Conf libqt4-sql (4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1 Debian:8.7/stable [i386])
Conf libqt4-declarative (4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1 Debian:8.7/stable [i386])
Conf libqt4-designer (4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1 Debian:8.7/stable [i386])
Conf libqt4-qt3support (4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1 Debian:8.7/stable [i386])
Conf libssh-gcrypt-4 (0.6.3-4+deb8u2 Debian:8.7/stable, Debian-Security:8/stable [i386])
Conf vlc-plugin-pulse (2.2.4-1~deb8u1 Debian:8.7/stable, Debian-Security:8/stable [all])
Conf phonon-backend-vlc (0.8.0-2 Debian:8.7/stable [i386])
Conf docbook-xsl (1.78.1+dfsg-1 Debian:8.7/stable [all])
Conf kate-data (4:4.14.2-2 Debian:8.7/stable [all])
Conf libdlrestrictions1 (0.15.15 Debian:8.7/stable [i386])
Conf libfam0 (2.7.0-17.1 Debian:8.7/stable [i386])
Conf libkdecore5 (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Conf libkdeui5 (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Conf libkcmutils4 (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Conf soprano-daemon (2.9.4+dfsg-1.1 Debian:8.7/stable [i386])
Conf libsoprano4 (2.9.4+dfsg-1.1 Debian:8.7/stable [i386])
Conf libnepomuk4 (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Conf libsolid4 (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Conf libstreams0 (0.7.8-1.2+b2 Debian:8.7/stable [i386])
Conf libstreamanalyzer0 (0.7.8-1.2+b2 Debian:8.7/stable [i386])
Conf libkio5 (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Conf libknewstuff3-4 (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Conf libnepomukquery4a (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Conf libnepomukutils4 (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Conf libkparts4 (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Conf libktexteditor4 (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Conf libkatepartinterfaces4 (4:4.14.2-2 Debian:8.7/stable [i386])
Conf katepart (4:4.14.2-2 Debian:8.7/stable [i386])
Conf kde-runtime-data (4:4.14.2-2 Debian:8.7/stable [all])
Conf libkjsapi4 (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Conf libkjsembed4 (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Conf libkrosscore4 (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Conf kdelibs-bin (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Conf kdelibs5-data (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [all])
Conf libxml2-utils (2.9.1+dfsg1-5+deb8u4 Debian:8.7/stable, Debian-Security:8/stable [i386])
Conf kdoctools (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Conf libutempter0 (1.1.5-4 Debian:8.7/stable [i386])
Conf libkpty4 (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Conf libkde3support4 (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Conf libkdewebkit5 (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Conf libkemoticons4 (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Conf libkfile4 (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Conf libkhtml5 (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Conf libkntlm4 (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Conf libpolkit-qt-1-1 (0.103.0-1 Debian:8.7/stable [i386])
Conf kdelibs5-plugins (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Conf oxygen-icon-theme (4:4.14.0-1 Debian:8.7/stable [all])
Conf libkdnssd4 (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Conf libthreadweaver4 (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Conf libplasma3 (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Conf plasma-scriptengine-javascript (4:4.14.2-2 Debian:8.7/stable [i386])
Conf libgpgme++2 (4:4.14.2-2+deb8u2 Debian:8.7/stable, Debian-Security:8/stable [i386])
Conf libkactivities6 (4:4.13.3-1 Debian:8.7/stable [i386])
Conf libkdeclarative5 (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Conf libkdesu5 (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Conf libkmediaplayer4 (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Conf libknotifyconfig4 (4:4.14.2-5+deb8u1 Debian:8.7/stable, Debian-Security:8/stable [i386])
Conf libkxmlrpcclient4 (4:4.14.2-2+deb8u2 Debian:8.7/stable, Debian-Security:8/stable [i386])
Conf ntrack-module-libnl-0 (016-1.3 Debian:8.7/stable [i386])
Conf libntrack0 (016-1.3 Debian:8.7/stable [i386])
Conf libntrack-qt4-1 (016-1.3 Debian:8.7/stable [i386])
Conf phonon (4:4.8.0-4 Debian:8.7/stable [i386])
Conf kde-runtime (4:4.14.2-2 Debian:8.7/stable [i386])
Conf krecipes-data (2.0~beta2-3 Debian:8.7/stable [all])
Conf kdebase-runtime (4:4.14.2-2 Debian:8.7/stable [all])
Conf libqimageblitz4 (1:0.0.6-4 Debian:8.7/stable [i386])
Conf krecipes (2.0~beta2-3 Debian:8.7/stable [i386])


Jeez. :? Looks like a systemd nightmare error during install to me. That is a lot of stuff. Unfortunately. I keep in shape riding bicycles and motorcycles in this desert heat. My wife cooks for me everyday so I eat good also. Plus I am active outdoors on a daily basis.
So I know nothing about what I am recommending in my post. Maybe, hopefully. Some other member will chime in on this thread.

Good luck with it.

_________________
Linux Registered User # 475019
Linux at Home courses
How to Search for AntiX solutions to your problems


Top
 Profile  
 
 Post subject: Re: Program to help lose weight,,recipe,diet,exercise, nutri
PostPosted: Wed Jan 18, 2017 3:57 pm 
Offline
User avatar

Joined: Fri Feb 20, 2009 3:44 am
Posts: 3957
Location: Pecos, Texas
Still searching @ http://wiki.linuxquestions.org/wiki/Lin ... s_software

Quote:
Requirements

SportsTracker is an application for the Java platform written in Java and Groovy. It was developed and tested with the Oracle JVM, other JVM implementations will probably work too.

The SportsTracker installer packages contain an embedded Java SE Runtime Environment (JRE), a Java installation is not needed. Users of binary packages need to install the JRE before, the Oracle JRE can be downloaded from the Java website.

If you want to download exercise files from your heartrate monitor you might need one of the tools listed above.

The application was tested on GNU/Linux (e.g. Ubuntu 16.04), Windows (7, 8, 10), Mac OS X (10.9 - 10.11) and FreeBSD (TrueOS with OpenJDK), although it should work on all systems with the required Java Runtime Environment.


http://www.saring.de/sportstracker/

some more
Gtrainer Use google search to find out more on gtrainer.

https://sourceforge.net/projects/pytrainer/ same advice using google search to study up on pytrainer

workrave

Body Building App

The Diary of Hercules

cycling

cycle atlas

Nut

Diet Monger *** Kicker

php running management

That's all I got thriftee. 8)

I left this one out. It is probably the closest to what you are looking for. It runs on linux or windows. But it costs money.

http://workoutware-com.software.informer.com/

however:

Quote:
WorkoutWare provides a free 30-day trial of the software that runs on Linux or Windows. Installation was simple on my Ubuntu desktop. I downloaded the Linux installer, changed the permissions, and ran it. The only speed bump was figuring out the command to run the application, which just required a visit to the installation directory. Open Fitness retails at $40 for the download version or $50 for the CD. A pro version that lets you manage an unlimited number of users sells for $90 or $100.

is a combination package with a lot of features that enable users to track diet, weight, measurements, workouts, and overall progress. Fitness trainers can use Open Fitness with multiple users, including a feature that allows users to log in to the Open Fitness network and access eating and workout programs specially created for them by the trainer.

_________________
Linux Registered User # 475019
Linux at Home courses
How to Search for AntiX solutions to your problems


Top
 Profile  
 
 Post subject: Re: Program to help lose weight,,recipe,diet,exercise, nutri
PostPosted: Thu Jan 19, 2017 1:38 am 
Offline

Joined: Thu Feb 09, 2012 7:29 am
Posts: 1092
The only food-related program I've used under linux is debian package "gourmet"
(it also runs under winXP. I discovered it when sis was looking for something that could
"import MealMaker recipe files")

it doesn't nag you to go out and excercise, it just helps with managing recipes/ingredients database and creates shopping lists


Top
 Profile  
 
 Post subject: Re: Program to help lose weight,,recipe,diet,exercise, nutri
PostPosted: Fri Jan 20, 2017 3:16 pm 
Offline

Joined: Fri Feb 27, 2009 10:17 am
Posts: 563
Thanks for all the suggestions..

I've thought through what makes Fitday work for me:

1. It has the default nutrition database
2. Tracks recipes, allows you to add new ones, but screws up if you change the resulting number of servings
3. Tracks meals with all nutrition
4. Tracks exercise and calories burned
5. Can see by day or week or month etc
6. Its proprietary so what doesn't work never will. I put requests for bug fixes in 5 years ago, never got any reply

I decided I would be ok if I could record negative servings of exercise to record calorie burn, ie have a recipe for Tennis that is 550 calories per 1 hr serving

Gourmet seems to have the recipes and nutrition, but in what I saw, it didn't do any tracking

Of the rest, Cronometer and Krecipes could do both recipes and tracking nutrition.

I got Krecipies installed on a test machine. What an install list! It took a very long time to linitialize. The database is painfully slow. I didn't try the exercise thing yet. Another way I could do that would be to do a bit of SQL on the exercise to reverse the sign if negatives aren't allowed..add it up for the meal, day, or week or month. It is running SQL Lite. Perhaps it would do better if I ran MySQL for the backend.

I plan to try Cronometer.

A third possibility would be to try Fitday under Wine.

A 4th possibility is to find a good online app, but that I've seen, those cost money.

Improvements possible... Being able to record what I ate/did on my phone during the day. I don't have a heart rate monitor with the ability to report, but if it was cheap it would be a nice option.

Again, thanks for the research efforts.

No need to mess up your system trying to install anything. Perhaps the KDE games didn't work due to systemd problems. I loaded Knoppix 7.7.1 (jessie version) and the same games do work there. On my antix 16 one I need to try them from a command line to see it there are clues to why they don't work from the menu.

_________________
Too many computers, in use now:
1-Dell D620 2gb
2-HP DV9917 4gb
3-Dell E5540 8gb
4-Dell Inspiron 15 7559 16gb
various older machines


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
suspicion-preferred