It is currently Fri Mar 24, 2017 12:07 am



Welcome
Welcome to antiX-forum.

You are currently viewing our boards as a guest, which gives you limited access to view most discussions and access our other features. By joining our free community, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content, and access many other special features. Registration is fast, simple, and absolutely free, so please, join our community today!


Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: Solved - Trouble installing OpenOffice 4.1.3
PostPosted: Sun Dec 11, 2016 11:01 pm 
Offline

Joined: Mon Oct 10, 2016 6:55 am
Posts: 34
Location: Clemmons, NC
Old habits die hard.

Because I had successfully loaded OO on several Windows machines and love the software I searched for download OpenOffice for LINUX. Found: http://www.tecmint.com/install-apache-o ... ra-ubuntu/ with what appeared to be good instructions for Debian. I got mixed up a couple of times because a 64 bit command was labeled 32 bit, etc. So I had to wait a while several times for a download to complete until I got the right combination and I got it to run all the way through - but with some errors because java wasn't available. I used the AntiX meta package loader to install java I thought and that seemed to run OK. But there were still some errors when I tried OO:

cd ..
wl@dv1000-antix1:/
$ sudo apt-get install openjdk-8-jre
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package openjdk-8-jre
wl@dv1000-antix1:/
$ openoffice4
javaldx: Could not find a Java Runtime Environment!
Gtk-Message: Failed to load module "gail"
Gtk-Message: Failed to load module "atk-bridge"

I've done a find for "gail" and "atk-bridge" but no joss.

Then I searched for 'Problems installing OpenOffice' on this forum and didn't find what I thought was a similar situation that was relatively recent.

I did try:

wl@dv1000-antix1:/
$ sudo apt-get install openoffice.org
[sudo] password for wl:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package openoffice.org is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Because it seemed so straightforward. But as you can see it didn't seem to do much.

I think I' m out of options..

Any comments/coaching/ would be greatly appreciated.


Last edited by INOV8TN on Wed Jan 11, 2017 4:54 am, edited 2 times in total.

Top
 Profile  
 
 Post subject: Re: Trouble installing OpenOffice 4.1.3
PostPosted: Mon Dec 12, 2016 5:58 am 
Offline

Joined: Thu Feb 09, 2012 7:29 am
Posts: 1045
lookit:
https://packages.debian.org/search?keyw ... ection=all
For openjdk8, seems you would need to add debian testing repo (or backports repo) to your sources.list

lookit:
The only openoffice package in debian stable is openoffice.org-dtd-officedocument1.0
To see the content across all repos, lookit:
https://packages.debian.org/search?keyw ... ection=all
version "4.1.3" (per your title) is not available from any of the debian repositories.

lookit:
a .deb file (64-bit) for OO version 4.1.3 is available here
http://www.openoffice.org/download/
If you need 32-bit, read here http://www.openoffice.org/porting/index.html


Top
 Profile  
 
 Post subject: Resolved - Re: Trouble installing OpenOffice 4.1.3
PostPosted: Tue Jan 03, 2017 10:00 pm 
Offline

Joined: Mon Oct 10, 2016 6:55 am
Posts: 34
Location: Clemmons, NC
Thanks to all for your views and suggestions.

I've decided to no longer pursue the installation and use of AOO on my AntiX PC at this time.

I have had the opportunity to install and summarily test the AntiX developer's choice of Office app s/w, LibreOffice. It seems appropriate for my use.

Thanks again.

Happy New Year!

- Bill


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
suspicion-preferred