It is currently Tue Aug 22, 2017 5:02 pm



Welcome
Welcome to antiX-forum.

You are currently viewing our boards as a guest, which gives you limited access to view most discussions and access our other features. By joining our free community, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content, and access many other special features. Registration is fast, simple, and absolutely free, so please, join our community today!


Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: What packages needed to compile?
PostPosted: Thu Apr 24, 2008 10:40 pm 
Offline

Joined: Thu Sep 13, 2007 3:34 am
Posts: 61
I have gcc, make, etc, installed, but I get:
ld: crt1.o: No such file

I have not been able to find a package that supplies this.

Perhaps I could get glibc-sources and build glibc, but seems to me this should be available as a package.

I see that others have been able to do compiles, so I assume it is just a matter of finding and installing the right packages,

I am using antiX-M7 with apt-get update;apt-get upgrade as of today.


Top
 Profile  
 
 Post subject:
PostPosted: Thu Apr 24, 2008 11:25 pm 
Offline
User avatar

Joined: Sun Oct 07, 2007 5:16 pm
Posts: 1520
Location: Canada's South Coast
apt-get install build-essential

This should give you everything you need to compile packages.

eriefisher


Top
 Profile  
 
 Post subject:
PostPosted: Fri Apr 25, 2008 2:23 am 
Offline

Joined: Thu Sep 13, 2007 3:34 am
Posts: 61
From the description, I thought build-essential was just stuff for making DEB packages, but it seems to pull in the other stuff I need. Now, I am working on other dependencies to get Inkscape 0.46 built.


Top
 Profile  
 
 Post subject:
PostPosted: Fri Apr 25, 2008 2:39 am 
Offline
User avatar

Joined: Sun Oct 07, 2007 5:16 pm
Posts: 1520
Location: Canada's South Coast
Inkscape-0.46-1 is in the sid repos if you want to enable them.

eriefisher


Top
 Profile  
 
 Post subject:
PostPosted: Fri Apr 25, 2008 6:34 am 
Offline

Joined: Thu Sep 13, 2007 3:34 am
Posts: 61
Thanks, I'll give it a try. I had looked in Debian Backports, but no luck. I didn't think to look in Sid as I have been hesitant to switch over to Sid.

Also, I did try the Inkscape "autopackage", but ran into too many dependency problems.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
suspicion-preferred