It is currently Tue May 23, 2017 10:31 pm



Welcome
Welcome to antiX-forum.

You are currently viewing our boards as a guest, which gives you limited access to view most discussions and access our other features. By joining our free community, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content, and access many other special features. Registration is fast, simple, and absolutely free, so please, join our community today!


Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: Major GRUB and Partition Issues
PostPosted: Sat Apr 21, 2012 10:13 pm 
Offline

Joined: Wed Nov 16, 2011 5:59 pm
Posts: 28
Hi AntiC and gang, happy weekend!

If this is the wrong forum, or wrong section of the forum, please let me know and I’ll correct that.

Summary:
Can’t do hard drive boot (GRUB failure)
Lost all data files (under my /home/joesmith directory)

Recovering data files most important right now

---------------------------

Details:

Had Antix M11 full hard-drive install, with swap. Worked fine.

/dev/sda1 antix partition (ext3)
/dev/sd2 swap

Decided to try out some other distributions, so booted Puppy Linux Live CD, ran
Partition Magic and created another small primary partition

/dev/sda1 antix partition (ext3)
/dev/sda2 swap
/dev/sda3 new partition (ext3)

Worked great, went back into AntiX.

Few days later, installed Mageia 1 on /dev/sda3. Worked fine, but appears it reconfigured/re-installed GRUB.

At hard-drive boot, there was a “primary” screen, with choices for Mageia and AntiX. The AntiX choice just took me back to the familiar AntiX screen, with 3 boot choices.
(like the menu was “nested”)

Decided to wipe Mageia, so installed Salix to /dev/sda3. It wanted to format the swap (/dev/sda2), so it did that too. I bypassed the request to install LILO (knowing I had GRUB).

Problems starting now…..

Rebooted. Black screen with word “GRUB” in top-left corner. Nothing else.

Booted Puppy Linux Live CD, and started Google-ing help.

** Still able to mount sda1, and see all my files.***

Ran cfdisk –lu. Error message: “Partition table entries are not in disk order”

Used cfdisk “expert” commands to re-order, and message went away:

/dev/sda1 antix partition (ext3)
/dev/sda2 new partition (ext3)
/dev/sda3 swap

Reboot, still black screen. Back to Puppy Linux.
Used GRUB Legacy tool to try to “fix” GRUB menu on /dev/sda1, which was silly, because it just replaced the perfectly-fine AntiX menu.list with “generic” entries.

Reboot, still black screen. Back to Puppy Linux – but now, much of my sda1 has been wiped out (mostly data files, many system files still in place)!! Happened at some point after fiddling around with Puppy tools.

And just my luck, my last system backup didn’t work properly. So I’ve lost some stuff for sure.

Need to take “time out” now LOL.

So my questions are:

Any chance of recovering my lost files? I’ve heard that photorec (http://www.cgsecurity.org/wiki/PhotoRec) can recover from really ugly situations – any opinions?

Can my GRUB mess be fixed without a hard-drive wipe-out? Also ran a GRUB scan tool, and it said something about not finding “Stage 2”. I can re-run the utility if need be.

Thanks for any tips!


Top
 Profile  
 
 Post subject: Re: Major GRUB and Partition Issues
PostPosted: Sat Apr 21, 2012 11:15 pm 
Offline
Site Admin
User avatar

Joined: Tue Sep 11, 2007 4:55 pm
Posts: 5803
Location: Greece
Boot antiX live cd and recover your files. You should also be able to re-install grub to mbr and it should then get antiX back up and running unless your 'fiddling' in Puppy has destroyed too much.

IMO It is best to use an older version of antiX for this ie antiX-M8.5-base or earlier. antiX-M11 grub recovery should be ok, but some have had issues.

_________________
Philosophers have interpreted the world in many ways; the point is to change it.


Top
 Profile  
 
 Post subject: Re: Major GRUB and Partition Issues
PostPosted: Sun Apr 22, 2012 2:20 am 
Offline

Joined: Wed Nov 16, 2011 5:59 pm
Posts: 28
Thanks so much, Anti! I will download 8.5 and try that ... I'm curious about the file recovery utility .... will see if it's just a "generic" utility or if there's "special" detection because the Live CD will see that I have Anti already installed.

I'll keep you posted


Top
 Profile  
 
 Post subject: Re: Major GRUB and Partition Issues
PostPosted: Sun Apr 22, 2012 11:45 pm 
You mentioned it yourself, else i wouldn't post (am a bit unsure if it is "dangerous"):
I just recovered a bunch of files and folders (11 Gigs) with photorec from testdisk.
It worked, like said.
Problem: i wouldn't call the usage intuitive. And i had to search for quite a while to find what i was looking for after it was recovered (the restored folder is a bit of a mess).

Reinstalling grub, otoh, is not hard. Boot a debian based live-CD, say antiX, mount the / of the install, say to /media/disk
mount -o bind /sys /media/disk/sys
mount -o bind /dev /media/disk/dev
mount -t proc /proc /media/disk/proc
and _if_ you got boot on a separate partition:
mount /dev/sd[a-z][0-9] /media/disk/grub
chroot
To chroot to it.
grub-install /dev/sda
assuming sda is where the mbr is supposed to be.

Mind you: i don't know the tool anticapitalista speaks of (grub recovery). It might be much better (more easy, more safe, more whatever).

this way, that way: good luck and take care (i wrote this from my memory, might contain errors)


Top
  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
suspicion-preferred