It is currently Fri Nov 28, 2014 4:45 am



Welcome
Welcome to antiX-forum.

You are currently viewing our boards as a guest, which gives you limited access to view most discussions and access our other features. By joining our free community, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content, and access many other special features. Registration is fast, simple, and absolutely free, so please, join our community today!


Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: Full install to a USB-HDD; doesn't boot :(
PostPosted: Thu Aug 11, 2011 7:37 am 
Offline
User avatar

Joined: Mon Jul 11, 2011 12:58 pm
Posts: 27
Location: Saanich, BC, Canada
Hi there!

I just tried to make a portable full boot of antiX on an external USB-HDD. It looked like everything went well. I installed it to /dev/sdc (sda is the computer hard drive and sdb was the USB flash drive I was running antiX Live from instead of a CD).

However, when I tried to boot from the new portable install of antiX, it didn't work. I was given the option of the existing system on the computer's hard drive or antiX. But when I selected antiX I got a message to the effect that the boot system couldn't be found.

Did I overlook something obvious? I partitioned the 320 GB USB-HDD to have a 6 GB swap space, and selected /dev/sdc as the GRUB location. I'm guessing I overlooked something else too...

Thanks!

_________________
M_Mynaardt


Top
 Profile  
 
 
 Post subject: Re: Full install to a USB-HDD; doesn't boot :(
PostPosted: Thu Aug 11, 2011 8:38 am 
Offline
User avatar

Joined: Fri Feb 20, 2009 3:44 am
Posts: 2784
Location: Pecos, Texas
Run the Live pen drive and post the /boot/grub/menu.lst that should be on the external hardrive.

Or. Try editing when you get to the grub screen where antix won't boot and edit the (hd2,0), in case that is what is shown and change it to (hd0,0)

My old 8.2 install instructions on how grub had to be edited on external Flash hardrive install is near middle of page.

http://yatsite.blogspot.com/2009/07/ins ... e-900.html

_________________
Linux Registered User # 475019
Takes a Lot of MONEY to create poverty.
Linux atHome courses
I Have a Masters in Raising Hell


Top
 Profile  
 
 Post subject: Re: Full install to a USB-HDD; doesn't boot :(
PostPosted: Thu Aug 11, 2011 4:08 pm 
Offline
User avatar

Joined: Mon Jul 11, 2011 12:58 pm
Posts: 27
Location: Saanich, BC, Canada
rokytnji wrote:
Run the Live pen drive and post the /boot/grub/menu.lst that should be on the external hardrive.

Or. Try editing when you get to the grub screen where antix won't boot and edit the (hd2,0), in case that is what is shown and change it to (hd0,0)

My old 8.2 install instructions on how grub had to be edited on external Flash hardrive install is near middle of page.

http://yatsite.blogspot.com/2009/07/ins ... e-900.html


Okay, right on, I'll give that a go!

Thanks!

_________________
M_Mynaardt


Top
 Profile  
 
 Post subject: Re: Full install to a USB-HDD; doesn't boot :(
PostPosted: Thu Aug 11, 2011 5:55 pm 
Offline
User avatar

Joined: Wed Oct 15, 2008 9:42 pm
Posts: 195
Location: Toulouse, France
You may also replace the boot=(hdx,0) by boot=UUID=xxxxx
where xxx is the UUID of the device

use (as root):
Code:
# blkid

to get the UUID of you disk

_________________
Yves
_____________________________________________________________
S'il n'y a pas de solutions, il n'y a pas de problèmes.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
suspicion-preferred