It is currently Thu Jun 29, 2017 5:50 am



Welcome
Welcome to antiX-forum.

You are currently viewing our boards as a guest, which gives you limited access to view most discussions and access our other features. By joining our free community, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content, and access many other special features. Registration is fast, simple, and absolutely free, so please, join our community today!


Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 13 posts ] 
Author Message
 Post subject: AntiX-16-RC1 bug report - Long shutdown
PostPosted: Tue Jun 14, 2016 1:05 pm 
Offline

Joined: Thu Apr 21, 2011 9:13 am
Posts: 137
Location: Berkshire, UK
(Only reported in case it affects other users - not an issue for me.)

A 32-bit install on a Thinkpad T41 takes a long time to shutdown. It waits at:

Code:
Stopping enhanced syslogd: rsyslogd


for 105 seconds.

A 32-bit install on other hardware does not do this.

Hardware affected:

Code:
[email protected]:~
$ inxi -F
System:    Host: antix6-32RC1 Kernel: 4.4.10-antix.1-486-smp i686 (32 bit)
           Desktop: IceWM 1.3.8
           Distro: antiX-16-RC1_386-full Berta Cáceres 13 June 2016
Machine:   System: IBM (portable) product: 23748RG v: ThinkPad T41
           Mobo: IBM model: 23748RG
           Bios: IBM v: 1RETDGWW (3.12 ) date: 10/18/2004
Battery    BAT0: charge: 35.2 Wh 98.9% condition: 35.6/47.5 Wh (75%)
CPU:       Single core Intel Pentium M (-UP-) cache: 1024 KB
           speed: 1600 MHz (max)
Graphics:  Card: Advanced Micro Devices [AMD/ATI] RV200/M7 [Mobility Radeon 7500]
           Display Server: X.Org 1.16.4 drivers: ati,radeon (unloaded: fbdev,vesa)
           Resolution: [email protected]
           GLX Renderer: Mesa DRI R100 (RV200 4C57) x86/MMX/SSE2 DRI2
           GLX Version: 1.3 Mesa 10.3.2
Audio:     Card Intel 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller
           driver: snd_intel8x0
           Sound: ALSA v: k4.4.10-antix.1-486-smp
Network:   Card-1: Intel 82540EP Gigabit Ethernet Controller (Mobile)
           driver: e1000
           IF: eth0 state: down mac: 00:0d:60:7a:ff:a3
           Card-2: Qualcomm Atheros AR5212 802.11abg NIC driver: ath5k
           IF: wlan0 state: up mac: 00:05:4e:46:db:02
Drives:    HDD Total Size: 31.9GB (15.1% used)
           ID-1: /dev/sda model: KingSpec_KSD size: 31.9GB
Partition: ID-1: / size: 28G used: 2.6G (10%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 2.17GB used: 0.00GB (0%) fs: swap dev: /dev/sda2
Sensors:   System Temperatures: cpu: 71.0C mobo: 45.0C
           Fan Speeds (in rpm): cpu: 3560
Info:      Processes: 129 Uptime: 2:16 Memory: 139.6/1002.9MB
           Client: Shell (bash) inxi: 2.3.0


Chris


Top
 Profile  
 
 Post subject: Re: AntiX-16-RC1 bug report - Long shutdown
PostPosted: Wed Jun 15, 2016 9:25 am 
Offline

Joined: Thu Apr 21, 2011 9:13 am
Posts: 137
Location: Berkshire, UK
Further info discovered:

Perusal of /var/log/syslog shows delay seems related to network. Disabling wireless and connecting via Ethernet made shutdown behave normally.

I will try to test on other hardware later this week.

Chris


Top
 Profile  
 
 Post subject: Re: AntiX-16-RC1 bug report - Long shutdown
PostPosted: Wed Jun 15, 2016 12:48 pm 
Offline
User avatar

Joined: Sun Dec 16, 2007 4:49 pm
Posts: 2149
Do you have an network shares mounted when you shutdown and expierence the long shutdown time?

_________________
http://www.youtube.com/runwiththedolphin
eeepc 904ha antix 15 32 bit (streaming media player)
sony laptop amd 900mhz duran 512mb ram, antix 13 32-bit
lenovo s21e - 2gb ram, celeron - antiX-16 64 bit


Top
 Profile  
 
 Post subject: Re: AntiX-16-RC1 bug report - Long shutdown
PostPosted: Wed Jun 15, 2016 1:04 pm 
Offline

Joined: Sun Aug 21, 2011 10:59 am
Posts: 995
dolphin_oracle wrote:
Do you have an network shares mounted when you shutdown and expierence the long shutdown time?
You beat me to asking the same question.


Top
 Profile  
 
 Post subject: Re: AntiX-16-RC1 bug report - Long shutdown
PostPosted: Wed Jun 15, 2016 4:34 pm 
Offline

Joined: Thu Apr 21, 2011 9:13 am
Posts: 137
Location: Berkshire, UK
dolphin_oracle wrote:
Do you have an network shares mounted when you shutdown and expierence the long shutdown time?


Yes; I will test with the share disconnected, and report.

Chris


Top
 Profile  
 
 Post subject: Re: AntiX-16-RC1 bug report - Long shutdown
PostPosted: Wed Jun 15, 2016 5:44 pm 
Offline

Joined: Thu Apr 21, 2011 9:13 am
Posts: 137
Location: Berkshire, UK
The circumstances needed to recreate the extended shut-down are mounted network shares, and a wireless connection.

If connected by Ethernet, shut-down is normal even with a connected share.

I will test on other hardware tomorrow; if others are affected, perhaps Disconnectshares should run automatically on shut-down?

Chris


Top
 Profile  
 
 Post subject: Re: AntiX-16-RC1 bug report - Long shutdown
PostPosted: Wed Jun 15, 2016 8:29 pm 
Offline
Site Admin
User avatar

Joined: Tue Sep 11, 2007 4:55 pm
Posts: 5839
Location: Greece
Since I do not use network sharing, I might be wrong here, but I would have thought that user would manually disconnect shares before shutting down or rebooting?

_________________
Philosophers have interpreted the world in many ways; the point is to change it.


Top
 Profile  
 
 Post subject: Re: AntiX-16-RC1 bug report - Long shutdown
PostPosted: Wed Jun 15, 2016 10:03 pm 
Offline
User avatar

Joined: Sun Dec 16, 2007 4:49 pm
Posts: 2149
anticapitalista wrote:
Since I do not use network sharing, I might be wrong here, but I would have thought that user would manually disconnect shares before shutting down or rebooting?


often that is not the case. you just shutdown. they are easy to forget after all.

we fixed this in antiX 13 and 15. sam reminded me. I'm looking for the fix as we speak.

_________________
http://www.youtube.com/runwiththedolphin
eeepc 904ha antix 15 32 bit (streaming media player)
sony laptop amd 900mhz duran 512mb ram, antix 13 32-bit
lenovo s21e - 2gb ram, celeron - antiX-16 64 bit


Top
 Profile  
 
 Post subject: Re: AntiX-16-RC1 bug report - Long shutdown
PostPosted: Wed Jun 15, 2016 10:19 pm 
Offline
User avatar

Joined: Sun Dec 16, 2007 4:49 pm
Posts: 2149
I sent the fix to anti, and test here OK. chris if you wouldn't mind testing.

extract the attached and place in / etc/init.d

run

Code:
sudo update-rc.d umountnfs-alternative.sh defaults


you might have to reboot for changes to go into effect. I'm not sure about that.

thanks to samk for reminding me of this.


Attachments:
umountnfs-alternative.zip [1.35 KiB]
Downloaded 52 times

_________________
http://www.youtube.com/runwiththedolphin
eeepc 904ha antix 15 32 bit (streaming media player)
sony laptop amd 900mhz duran 512mb ram, antix 13 32-bit
lenovo s21e - 2gb ram, celeron - antiX-16 64 bit


Last edited by dolphin_oracle on Wed Jun 15, 2016 10:36 pm, edited 1 time in total.
Top
 Profile  
 
 Post subject: Re: AntiX-16-RC1 bug report - Long shutdown
PostPosted: Wed Jun 15, 2016 10:23 pm 
Offline
Site Admin
User avatar

Joined: Tue Sep 11, 2007 4:55 pm
Posts: 5839
Location: Greece
I never got that fix, or I don't remember getting it.
Will include in upgraded deb

_________________
Philosophers have interpreted the world in many ways; the point is to change it.


Top
 Profile  
 
 Post subject: Re: AntiX-16-RC1 bug report - Long shutdown
PostPosted: Wed Jun 15, 2016 11:06 pm 
Offline
Site Admin
User avatar

Joined: Tue Sep 11, 2007 4:55 pm
Posts: 5839
Location: Greece
New connectshares deb soon to appear in repo to (hopefully) fix this problem

_________________
Philosophers have interpreted the world in many ways; the point is to change it.


Top
 Profile  
 
 Post subject: Re: AntiX-16-RC1 bug report - Long shutdown
PostPosted: Thu Jun 16, 2016 8:28 am 
Offline

Joined: Thu Apr 21, 2011 9:13 am
Posts: 137
Location: Berkshire, UK
dolphin_oracle wrote:
I sent the fix to anti, and test here OK. chris if you wouldn't mind testing.


Tested and working fine now; thanks.

Chris


Top
 Profile  
 
 Post subject: Re: AntiX-16-RC1 bug report - Long shutdown
PostPosted: Thu Jun 16, 2016 10:14 am 
Offline

Joined: Sun Aug 21, 2011 10:59 am
Posts: 995
chrispop99 wrote:
The circumstances needed to recreate the extended shut-down are mounted network shares, and a wireless connection.
[...]
Tested and working fine now; thanks.
dolphin_oracle wrote:
we fixed this in antiX 13 and 15. sam reminded me. I'm looking for the fix as we speak.
Thanks for picking up the ball on this.


BACKGROUND
Referring back to February 2014; at that time a web search revealed large numbers of Debian users were reporting the problem of a pause during shut-down. A fix was not introduced by Debian and is unlikely to be following the move to systemD. antiX inherited the unwanted behaviour because of its Debian parentage, and it remains in place because of our retention of sysvinit.

Connectshares cannot avoid a problem of that nature and is not causing it. Shares mounted via standard Linux mount techniques (i.e. not using helpers such as Connectshares) also exhibit the pause symptoms at shut-down if they are not unmounted before beforehand. The unwanted behaviour originates from upstream Debian.

The problem stems from the sequence in which the Debian init.d system stops services. The short version is, wireless networking is stopped before shares are unmounted. In turn this generates the time-out delay later in reboot/shut-down process.

The standard Debian file at the heart of the problem is / etc/init.d/umountnfs.sh. Its purpose is shown in the following abstract from the file.
Code:
Abstract starts
# Short-Description: Unmount all network filesystems except the root fs.
# Description:       Also unmounts all virtual filesystems (proc,
#                    devpts, usbfs, sysfs) that are not mounted at the
#                    top level.
Abstract ends

The previously submitted fix is named unmountnfs-alternative.sh. It is identical to unmountnfs.sh except for one minor amendment. Towards the head of the file, "Provides" now indicates "umountnfs-alternative". The fix runs its links earlier in the init.d sequence which prevents the pause condition and allows the reboot/shut-down to continue without a delay.

The result is neutral for systems that do not have the initial problem, beneficial for those that do, and transparent for all.


SUGGESTION
anticapitalista wrote:
New connectshares deb soon to appear in repo to (hopefully) fix this problem
Probably it is best to implement the fix outside of Connectshares. Because this problem is not caused by Connectshares, it will be of most benefit when the fix is not tied to it. In that way the fix will be available to systems which use share mounting techniques other than Connectshares. Perhaps incorporating it into the basic antiX build might be a better approach.


Top
 Profile  
 
Display posts from previous:  Sort by  
Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 13 posts ] 


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
suspicion-preferred