It is currently Sat May 27, 2017 4:23 am



Welcome
Welcome to antiX-forum.

You are currently viewing our boards as a guest, which gives you limited access to view most discussions and access our other features. By joining our free community, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content, and access many other special features. Registration is fast, simple, and absolutely free, so please, join our community today!


Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 26 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: antiX 14r boot problem on older Pentium III m cpu's
PostPosted: Wed Nov 26, 2014 5:55 pm 
Offline

Joined: Fri Feb 27, 2009 10:17 am
Posts: 566
This is the branch that seems to be moving forward, so I'd like to get it running. I saw 2 other people that tried it and had the same problem as me where the boot process hangs with the last thing on the screen setting the rtc_cmos 00:06. If help is needed to test code, I'd be willing if I could get it to boot or working on getting it to boot.

I will get the exact text off the screen and type it in and update the post

_________________
Too many computers, in use now:
1-Dell D620 2gb
2-HP DV9917 4gb
3-Dell E5540 8gb
4-Dell Inspiron 15 7559 16gb
various older machines


Top
 Profile  
 
 Post subject: Re: antiX 14r boot problem on older Pentium III m cpu's
PostPosted: Wed Nov 26, 2014 6:15 pm 
Offline
Site Admin
User avatar

Joined: Tue Sep 11, 2007 4:55 pm
Posts: 5804
Location: Greece
If you try latest antiX-14 alpha, try booting with nomodeset cheat at boot menu.

BTW I got my PIII to boot with that cheat with the very latest antiX kernel

Code:
inxi -F
System:    Host: antix1 Kernel: 3.17.2-antix.3-486 i686 (32 bit) Console: tty 0
           Distro: antiX-14R-alpha1_386-full Killah P 21 April 2014
Machine:   System: VIA product: VT82C693/A
           Mobo: Gigabyte model: 693A-596B-8671 Bios: Award v: 4.51 PG date: 07/06/00
CPU:       Single core Pentium III (Coppermine) (-UP-) cache: 256 KB speed: 731 MHz (max)
Graphics:  Card: NVIDIA NV17 [GeForce4 MX 440]
           Display Server: X.org 1.16.1.901 drivers: vesa,nouveau (unloaded: fbdev)
           tty size: 159x71 Advanced Data: N/A out of X
Audio:     Card Creative Labs SB Live! EMU10k1 driver: snd_emu10k1 Sound: ALSA v: k3.17.2-antix.3-486
Network:   Card: Realtek RTL8169 PCI Gigabit Ethernet Controller driver: r8169
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: 00:1e:2a:b7:56:34
Drives:    HDD Total Size: 120.0GB (5.1% used) ID-1: /dev/sda model: ST3120026A size: 120.0GB
Partition: ID-1: / size: 110G used: 5.1G (5%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 0.81GB used: 0.00GB (0%) fs: swap dev: /dev/sda2
Sensors:   None detected - is lm-sensors installed and configured?
Info:      Processes: 68 Uptime: 5 min Memory: 68.1/498.1MB Init: SysVinit runlevel: 5
           Client: Shell (bash) inxi: 2.2.16

_________________
Philosophers have interpreted the world in many ways; the point is to change it.


Top
 Profile  
 
 Post subject: Re: antiX 14r boot problem on older Pentium III m cpu's
PostPosted: Wed Nov 26, 2014 6:22 pm 
Offline

Joined: Fri Feb 27, 2009 10:17 am
Posts: 566
Ok, I will try the nomodeset too.

I am working on trying the MX-14.2 with the 3.16.0.bpo.3-686-pae kernel now with the old machine and will reburn the 14r latest to USB on this machine while that runs

_________________
Too many computers, in use now:
1-Dell D620 2gb
2-HP DV9917 4gb
3-Dell E5540 8gb
4-Dell Inspiron 15 7559 16gb
various older machines


Top
 Profile  
 
 Post subject: Re: antiX 14r boot problem on older Pentium III m cpu's
PostPosted: Wed Nov 26, 2014 6:31 pm 
Offline

Joined: Fri Feb 27, 2009 10:17 am
Posts: 566
Ok, it boots ok on MX-14.2 with the 3.16.0.bpo.3-686-pae kernel

will now try 14r3.2 with nomodeset and nousb2

_________________
Too many computers, in use now:
1-Dell D620 2gb
2-HP DV9917 4gb
3-Dell E5540 8gb
4-Dell Inspiron 15 7559 16gb
various older machines


Top
 Profile  
 
 Post subject: Re: antiX 14r boot problem on older Pentium III m cpu's
PostPosted: Wed Nov 26, 2014 6:51 pm 
Offline

Joined: Fri Feb 27, 2009 10:17 am
Posts: 566
Ok, I got it to the error. Maybe its related to me trying to boot it from a USB flash drive... I created it under Rufus on Windows Vista, but could use unetbootin if that might be the problem. Rufus usually has no problem and is much faster. I could also reboot the vista machine under linux and mount the vista partition and burn it that way if i knew how if that would remove all doubt.

i got it to do a 1280/1024 console so now i can see more of the problem

It finds the usb and then the hub and 2 ports... then

fusbh200_hcd: FUSBH200 Host Controller (EHCI) Driver
Warning! fusbh200_hcd should always be loaded before uhci_hcd and ohci_hcd, not after
usbcore: registered new interface driver usb-storage
...... big snip...
registered taskstats version 1
fbcondecor: switched decor state to 'on' on console 0
hd: no drives specified - use hd=cyl,head,sectors on kernel command line
rtc_cmos 00:06: setting system clock to 2014-11-26 16:39:13 UTC (1417019953)
_

and it hangs there....

I am reburning the USB flash drive with Unetbootin now and will update this post after I try it...

Same error when flash drive is created with Unetbootin, so Rufus isn't the problem.

The DVD drive is flaky, so I can't boot from it. The only other thing I can think of is to put the ISO onto a hard drive partition and somehow tell it to boot from there, but I don't know a way to do that, but that would prove whether the problem is with loading from the USB or not.

It seems to me like its related to trying to load from the USB, and I don't understand why its just this OS having the problem?

_________________
Too many computers, in use now:
1-Dell D620 2gb
2-HP DV9917 4gb
3-Dell E5540 8gb
4-Dell Inspiron 15 7559 16gb
various older machines


Top
 Profile  
 
 Post subject: Re: antiX 14r boot problem on older Pentium III m cpu's
PostPosted: Wed Nov 26, 2014 7:35 pm 
Offline
User avatar

Joined: Tue Sep 01, 2009 12:48 am
Posts: 1125
thriftee wrote:
will now try 14r3.2 with nomodeset and nousb2
Was nousb2 previously required to boot on this box? If so then we may need make some modifications to account for the new fusbh200-hcd driver.

_________________
Science is the belief in the ignorance of experts.
-- Richard Feynman


Top
 Profile  
 
 Post subject: Re: antiX 14r boot problem on older Pentium III m cpu's
PostPosted: Wed Nov 26, 2014 9:05 pm 
Offline
User avatar

Joined: Fri Feb 20, 2009 3:44 am
Posts: 3983
Location: Pecos, Texas
Quote:
I saw 2 other people that tried it and had the same problem


I don't know if you mean me or not?

post34908.html#p34908
antix-14r-alpha2-available-t5168-30.html
antix-14r-alpha3-available-for-testing-t5305-90.html


I sold that laptop. So my only old gear now for 32bit testing is a IBM T23 Laptop and a IBM M41 Desktop and a Panasonic CF-48 laptop and a Amrel RT 786 EX laptop.

The sweet spot kernel on mine has been
post35650.html#p35650

which I mailed the kernel config to Anti a while back. I do not know if my T23 still has it or not. I need to fire it up and check.

Edit: Yep. I still have it.

Code:
$ inxi -S
System:    Host: biker Kernel: 3.14.3-dreamlinux-liquorix i686 (32 bit)
           Desktop: IceWM 1.3.7 Distro: antiX-13_386-full Luddite 01 June 2013


I never could get 14 to step up on here though. From 14r1 on up.
But I am a patient grasshopper. :lol:

_________________
Linux Registered User # 475019
Linux at Home courses
How to Search for AntiX solutions to your problems


Top
 Profile  
 
 Post subject: Re: antiX 14r boot problem on older Pentium III m cpu's
PostPosted: Wed Nov 26, 2014 11:49 pm 
Offline

Joined: Fri Feb 27, 2009 10:17 am
Posts: 566
no, it was fronkenstein and jmeau.... if i recall had the problem too

I didn't try nousb2 before... i will try again without.

Same exact errors without nousb2
Same exact errors with from=usb
Same exact errors with mount=usb
Same exact error with nomodeset

_________________
Too many computers, in use now:
1-Dell D620 2gb
2-HP DV9917 4gb
3-Dell E5540 8gb
4-Dell Inspiron 15 7559 16gb
various older machines


Top
 Profile  
 
 Post subject: Re: antiX 14r boot problem on older Pentium III m cpu's
PostPosted: Thu Nov 27, 2014 12:13 am 
Offline

Joined: Fri Feb 27, 2009 10:17 am
Posts: 566
Hmmmmm,

I dug out a 14ra2 386 full dvd disc I had burned, and after a few tries got it booted to the same exact error.

That eliminates the trying to boot from Unetbootin USB Flash drive as the cause.

Which leaves the machine itself as the cause... The machine only has had problems in the past with its nVidia Geforce 2 Go card, but that hasn't been a problem with newer kernels that don't require the proprietary nVida code.

I will go over to it and reboot again under 14.2 and update this post with the inxi output...

Code:
[email protected]:/home/bobc# inxi -Fxz
System:    Host: d8100 Kernel: 3.16-0.bpo.3-686-pae i686 (32 bit gcc: 4.6.3)
           Desktop: Xfce 4.10.2 (Gtk 2.24.10)
           Distro: MX-14.2 Symbiosis 30 June 2014
Machine:   Mobo: Dell model: Inspiron 8100 Bios: Dell v: A08 date: 12/21/2001
CPU:       Single core Intel Pentium III Mobile (-UP-) cache: 512 KB
           flags: (pae sse) bmips: 1993 clocked at 1000 MHz
Graphics:  Card: NVIDIA NV11 [GeForce2 Go] bus-ID: 01:00.0
           Display Server: X.org 1.12.4 drivers: nouveau (unloaded: fbdev,vesa)
           tty size: 80x25 Advanced Data: N/A for root
Audio:     Card ESS ES1983S Maestro-3i PCI Audio Accelerator
           port: dc00 bus-ID: 02:03.0
           Sound: Advanced Linux Sound Architecture v: k3.16-0.bpo.3-686-pae
Network:   Card-1: Intersil ISL3886 [Prism Javelin/Prism Xbow] bus-ID: 0d:00.0
           IF: N/A state: N/A speed: N/A duplex: N/A mac: N/A
           Card-2: Intel 82557/8/9/0/1 Ethernet Pro 100
           driver: e100 v: 3.5.24-k2-NAPI port: ecc0 bus-ID: 08:04.0
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 30.0GB (12.5% used)
           ID-1: /dev/sda model: HITACHI_DK23CA size: 30.0GB temp: 48C
Partition: ID-1: / size: 5.3G used: 3.1G (62%) fs: ext4 dev: /dev/sda9
           ID-2: swap-1 size: 0.51GB used: 0.00GB (0%) fs: swap dev: /dev/sda2
Sensors:   System Temperatures: cpu: 51.5C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 121 Uptime: 3 min Memory: 135.4/500.0MB
           Init: SysVinit runlevel: 5 Gcc sys: 4.7.2
           Client: Shell (bash 4.2.371) inxi: 2.1.28
[email protected]:/home/bobc#

_________________
Too many computers, in use now:
1-Dell D620 2gb
2-HP DV9917 4gb
3-Dell E5540 8gb
4-Dell Inspiron 15 7559 16gb
various older machines


Top
 Profile  
 
 Post subject: Re: antiX 14r boot problem on older Pentium III m cpu's
PostPosted: Thu Nov 27, 2014 2:19 am 
Offline

Joined: Fri Feb 27, 2009 10:17 am
Posts: 566
If I put that same DVD into a Dell Latitude D620 laptop (newer than the old P III m) it boots fine. I tried Ctrl-S to pause the screen while it was booting to be able to read, but it goes by too fast, so I look at dmesg and see the same errors noted above.

The next lines to appear after where the older PC hangs says
Code:
Freeing unused kernel memory: 544K (c171b000 - c17a3000)
usb 2-2: New USB device found. idVendor=413c, idProduct=7761
....etc


So maybe its hanging while trying to free the memory or maybe on the usb 2 stuff (since the older machine is only usb 1 I think)?

I admit I'm stumped at this point... If anyone has any ideas please let me know if you want me to try something...

Thanks for the help. And BTW, after booting the antiX 14r2 I can say I like it a lot better than the MX-14.2 look and feel wise, not that there is anything wrong with the MX version, its just that I like the IceWM setup better, and to me its cleaner and much quicker.

_________________
Too many computers, in use now:
1-Dell D620 2gb
2-HP DV9917 4gb
3-Dell E5540 8gb
4-Dell Inspiron 15 7559 16gb
various older machines


Top
 Profile  
 
 Post subject: Re: antiX 14r boot problem on older Pentium III m cpu's
PostPosted: Tue Dec 02, 2014 1:34 am 
Offline

Joined: Mon Jun 16, 2014 11:10 pm
Posts: 19
Just to confirm: I also tried antix14R-alpha3 with an old laptop (Pentium III) and got same error as mentioned above: post38303.html#p38303

Also think the error is related with booting from usb (usb 1.0 in that old laptop). In my case (due to a flaky CD-ROM) the boot process is:
- Boot with Plop (http://www.plop.at/en/bootmanager/) in CD-ROM,
- Then, use Plop menu to select boot from usb (bootable usb pendrive created with YUMI)
(this process works OK with antix 13.2)


Top
 Profile  
 
 Post subject: Re: antiX 14r boot problem on older Pentium III m cpu's
PostPosted: Tue Dec 02, 2014 2:15 am 
Offline

Joined: Fri Feb 27, 2009 10:17 am
Posts: 566
Well, my laptop hit the same error when trying to boot from the DVD drive, so in my case it isn't caused by trying to boot from USB, but yes I also get the error if I try to boot from USB.

I haven't seen anywhere in the BIOS that I can turn off the USB ports, either.

I wonder if the correlating factor is that its machines that have USB 1.1, not 2.0?

I found a post on Dell's support board saying mine is 1.1......

These are all USB 1.1

http://www.intel.com/support/graphics/s ... -prd39.htm

* Intel 82371AB PCI to USB Universal Host Controller
* Intel 82371AB/EB PCI to USB Universal Host Controller
* Intel 82371SB PCI to USB Universal Host Controller
* Intel 82801AA PCI to USB Universal Host Controller
* Intel 82440MX PCI to USB Universal Host Controller
* Intel 82801BA/BAM USB Universal Host Controller - 2442
* Intel 82801BA/BAM USB Universal Host Controller - 2444
* Intel 82801CA/CAM USB Universal Host Controller - 2482
* Intel 82801CA/CAM USB Universal Host Controller - 2484
* Intel 82801CA/CAM USB Universal Host Controller - 2487

They tend to be built into windows or require the Chipset utility. AKA intel 810/815/820/845/850 chipsets.

PS: even though I have entered boot option "nousb2" and this machine doesn't support USB 2.0, when I put the screen into 1280x1024 mode and tell it to do a command line install from the boot menu off the DVD I can see it trying to use USB 2.0. I see a line that says:

ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver

later on it is loading a different driver for USB 1.1
ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver

_________________
Too many computers, in use now:
1-Dell D620 2gb
2-HP DV9917 4gb
3-Dell E5540 8gb
4-Dell Inspiron 15 7559 16gb
various older machines


Top
 Profile  
 
 Post subject: Re: antiX 14r boot problem on older Pentium III m cpu's
PostPosted: Sat Dec 20, 2014 3:48 am 
Offline

Joined: Fri Feb 27, 2009 10:17 am
Posts: 566
I'm thinking of loading the jesse beta onto it. I wonder it there is a easy way to see what kernel options are included as compared ti antix?

_________________
Too many computers, in use now:
1-Dell D620 2gb
2-HP DV9917 4gb
3-Dell E5540 8gb
4-Dell Inspiron 15 7559 16gb
various older machines


Top
 Profile  
 
 Post subject: Re: antiX 14r boot problem on older Pentium III m cpu's
PostPosted: Sat Dec 20, 2014 9:39 am 
Offline

Joined: Thu Feb 09, 2012 7:29 am
Posts: 1143
I had expected to find kernel config at /proc/config.gz but didn't...
so I asked where to look and (roky, IIRC) pointed me to /boot/config-$(uname -r)

I don't know what the differences are compared to stock kernels provided by debian.


Top
 Profile  
 
 Post subject: Re: antiX 14r boot problem on older Pentium III m cpu's
PostPosted: Sat Dec 20, 2014 10:42 am 
Offline

Joined: Fri Feb 27, 2009 10:17 am
Posts: 566
The Jessie beta boots fine in it and is installing, but its a 4-5 hr install

_________________
Too many computers, in use now:
1-Dell D620 2gb
2-HP DV9917 4gb
3-Dell E5540 8gb
4-Dell Inspiron 15 7559 16gb
various older machines


Top
 Profile  
 
Display posts from previous:  Sort by  
Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 26 posts ]  Go to page 1, 2  Next


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
suspicion-preferred